Πρόβλημα εγκατάστασης MANJARO XFCE 20.0.1

Καλησπέρα,

Πριν 3 περίπου μέρες και χωρίς εμπειρία, προσπάθησα να εγκαταστήσω την συγκεκριμένη έκδοση σε παλιό υπολογηστή (mb : ASUS COMMANDO, cpu : INTEL CORE 2, mem 4g) χωρίς επιτυχία…
Συγκεκριμένα στο 50 % βγαίνει error : installation failed failed to unpack image "/run/miso/bootmnt/manjaro/x86_64/rootfs.sfs" rsync failed with error code 11.
Εχω δοκιμάσει manual partitions, automatic (erase disk ) , gparted κλπ
Εχω εγκαταστησει με διαφορους τρόπου το iso , το εχω ελένξει κλπ . Δεν γίνεται ΤΙΠΟΤΑ…
Πριν απο αυτό το pc έτρεχε windows 10 χωρίς πρόβλημα…
Μήπως μπορείτε να βοηθήσετε?

Ευχαριστώ!!

Έχεις χρησιμοποιήσει το Rufus για να περάσεις το ISO στο στικάκι;

Ναι φυσικά… μετά το ventoy και τώρα πάλι rufus…

Εγώ θα σου πρότεινα να ξανακατεβάσεις το ISO και να ξανδοκιμάσεις.

το έκανα άπειρες φορές… και σήμερα το ίδιο

Δοκίμασε με το ίδιο ISO να κάνεις εγκατάσταση σε VirtualBox, να δεις αν χτυπάει το ίδιο λάθος.

το virtual box δεν χρειαζεται προεγκατεστημένο σύστημα?
Εγώ τώρα δεν έχω

Το error code 11 του rsync δηλώνει έλλειψη χώρου. Αυτό σημαίνει είτε ότι κάποιο partition δεν έχει αρκετό μέγεθος είτε ότι ο δίσκος έχει πρόβλημα, με αποτέλεσμα να «εξαφανίζεται» κατά τη διάρκεια της εγκατάστασης.

Έχεις δίκιο. Δεν αναφέρθηκε και το μέγεθος του σκληρού δίσκου και τι επιλογή γίνονται στα partitions.

300gb
υπαρχει και το αυτόματο install που διαγράφει τα παντα…

πιστευω ότι γίνεται κάποιο conflict εκει… όμως δεν μπορώ να το καταλάβω

Όσο είσαι στο live θα βοηθούσε ίσως αν έπαιρνες screenshot από την διαδικασία, να δούμε πώς είναι διαμορφωμένοι οι δίσκοι κλπ.

Δοκίμασε να δημιουργήσεις το iso και με την dd.

εδώ είμαι στο manual partition (στο τέλος δεν με αφήνει να προχωρήσω)

![image1|666x500]

εδω σε GPT mode… Βέβαια έχω παλιά εκδοση dos αλλά είπα να δοκιμάσω

και το auto!

βρέθηκε το λάθος!

δεν έχεις ορίσει ρουτ κατάτμηση / αλλά έχεις ορίσει /boot το οποίο εδώ μάλιστα που έχεις BIOS δεν χρειάζεσαι καθόλου. Δηλαδή άλλαξε το /boot σε σκέτο /

(αναφέρομαι στο mount point)

Να προσθέσω ότι δεν έχεις ισχυρό λόγο να έχεις ούτε ξεχωριστό /home και ούτε καν swap! (αντί για swap μπορείς να έχεις swap file). Πάντως το λάθος είναι ότι δεν έχεις /

EDIT: έχεις κάνει λάθος και στην επιλογή για τον bootloader. Έχεις BIOS άρα θα είναι στο MBR που είναι κατευθείαν στο /dev/sda. Και θέλω να πιστεύω ότι έχεις ms-dos πίνακα και όχι gpt.

4 Likes

Πολύ λογική παρατήρηση, όμως στο τελευταίο screenshot (που είναι το “auto”) δεν ισχύει η διαπίστωσή σου… Εκεί έχει και root κι από όλα τα καλά. Στην περίπτωση του auto partitioning κτλ κάτι άλλο φταίει. Που ίσως να φταίει και στις άλλες περιπτώσεις…

2 Likes

Εκεί ούτε και γω ξέρω… Αλλά το χειροκίνητο το κάνει ξεκάθαρα λάθος.

1 Like

δοκιμασε να διαμορφωσεις τις κατατμησεις οπως θελεις με το gparted και μετα κανε εγκατασταση. πχ ενα διαμερισμα root ενα για αρχεια ενα swap κλπ κλπ . μετα με την χειροκινητη εγκατασταση βαλε το λειτουργικο εκει πους θελεις.

1 Like

Τελικά αν και σωστή παρατήρηση όσον αφορά το θέμα του / το αποτέλεσμα ήταν το ίδιο… Είχα ξανακάνει πριν 2 μέρες manual εγκατάσταση χωρίς swap και πρέπει να είχα βάλει και το / αφού με είχε αφήσει να προχωρήσω μέχρι το 50% . Φυσικά και υπάρχει η δυνατότητα να μπουν partitions και για λογους Ασφάλειας Αποθηκευμένων αρχείων (video μουσική doc) σε περίπτωση που χρειαστεί πάλι εγκατάσταση …
Για το θέμα του swap οι απόψεις διίστανται αφού εξαρτάται και από το μεγεθος της μνήμης του συστήματος κλπ πάντως δεν θεωρείται λάθος ίσως σε περιπτώσεις περιττό (ειδικά σε καινούργιους υπολογιστές με αρκετή ram).
Το θέμα βέβαια είναι ότι παρόλο που η χειροκίνητη εγκατάσταση προχώρησε με τις διορθωσεις που αναφέρατε κόλλησε στο ίδιο σημείο .
Το παλεύω εδώ και τουλάχιστον 3 μέρες… Πριν καμία ώρα δοκίμασα να εγκαταστήσω το mint cinnamon με το ίδιο flash και το ventoy . Ευτυχώς όλα πήγαν καλά με την πρώτη!! κανένα error και άμεση εγκατάσταση (στο αυτόματο). Χάρηκα γιατί τουλάχιστον δεν φταίει ο δίσκος κλπ
Ισως υπάρχει ασυμβατοτητα μεταξύ του calamares και του παλιού συστήματος που έχω??
Δεν το έχω παρατήσει όμως … θα ήθελα να βρω λύση… Οποιαδήποτε οδηγία/υπόδειξη είναι ευπρόσδεκτη!!
Ευχαριστώ για τον χρόνο σας

Δες την 2η απάντηση εδώ : https://unix.stackexchange.com/questions/330380/manjaro-install-error-bad-source

1 Like

ναι στο φόρουμ τού Manjaro για το ίδιο πρόβλημα

Please use DD or Etcher to create the Manjaro Install Media.
Other options (like MultiSystem) is not supported.

1 Like