Δεν γινεται εγκατασταση drivers για εκτυπωτη epson

Εχω τον scaner epson v19. Ενω σε αλλες διανομες η εγκατασταση των οδηγων γινονταν κανονικα, στο Zorin 15.3 δεν γινεται τιποτα. Στο τερματικο βγαζει αυτα.

nikos@nikos-MS-7A34:/mnt/5448189B48187E44/ubuntu terminal orders/imagescan-bundle-ubuntu-20.04-3.63.0.x64.deb$ sudo ./install.sh
[sudo] password for nikos:     
Hit:1 https://repo.steampowered.com/steam stable InRelease
Hit:2 http://ppa.launchpad.net/zorinos/apps/ubuntu bionic InRelease            
Hit:3 http://archive.canonical.com/ubuntu bionic InRelease                     
Hit:4 http://security.ubuntu.com/ubuntu bionic-security InRelease              
Hit:5 http://archive.ubuntu.com/ubuntu bionic InRelease                        
Hit:6 http://gr.archive.ubuntu.com/ubuntu bionic-updates InRelease             
Hit:7 http://gr.archive.ubuntu.com/ubuntu bionic-backports InRelease           
Hit:8 http://ppa.launchpad.net/zorinos/drivers/ubuntu bionic InRelease         
Hit:9 http://ppa.launchpad.net/zorinos/patches/ubuntu bionic InRelease         
Hit:10 http://ppa.launchpad.net/zorinos/stable/ubuntu bionic InRelease         
Hit:11 https://packages.zorinos.com/stable bionic InRelease                    
Hit:12 https://packages.zorinos.com/patches bionic InRelease
Hit:13 https://packages.zorinos.com/apps bionic InRelease
Hit:14 https://packages.zorinos.com/drivers bionic InRelease
Reading package lists... Done                       
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libboost-filesystem1.71.0
E: Couldn't find any package by glob 'libboost-filesystem1.71.0'
E: Couldn't find any package by regex 'libboost-filesystem1.71.0'
E: Unable to locate package libboost-program-options1.71.0
E: Couldn't find any package by glob 'libboost-program-options1.71.0'
E: Couldn't find any package by regex 'libboost-program-options1.71.0'
E: Unable to locate package libgcc-s1
E: Unable to locate package libgcc-s1
E: Unable to locate package libgcc-s1

Απο που το κατέβασες το αρχείο ? Έχει κατάληξη imagescan-bundle-ubuntu-20.04-3.63.0.x64.deb ?

Αν ναι τοτε το κάνεις εγκατάσταση απευθείας. δεν το κάνεις εξαγωγή:

sudo apt install ./ imagescan-bundle-ubuntu-20.04-3.63.0.x64.deb

Τέλος όπως βλέπεις το πακέτο γράφει έκδοση 20.04-χχχχ που σημαίνει οτι δεν είναι συμβατό με το Zorin αλλά με το Ubuntu 20.04.

1 Like

Ειναι κατεβασμενο απο το site της epson.
http://download.ebz.epson.net/dsc/search/01/search/searchModule
Βαζεις perfection v19 και linux λειτουργικο.

Στην εγκατασταση βγαζει αυτο.


nikos@nikos-MS-7A34:/mnt/5448189B48187E44/ubuntu terminal orders/imagescan-bundle-ubuntu-20.04-3.63.0.x64.deb/core$ sudo apt install ./imagescan_3.63.0-1epson4ubuntu20.04_amd64.deb
[sudo] password for nikos:     
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'imagescan' instead of './imagescan_3.63.0-1epson4ubuntu20.04_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 imagescan : Depends: libboost-filesystem1.71.0 but it is not installable
             Depends: libboost-program-options1.71.0 but it is not installable
             Depends: libgcc-s1 (>= 3.0) but it is not installable
             Depends: libpangomm-1.4-1v5 (>= 2.42.0) but 2.40.1-4 is to be installed
             Depends: libstdc++6 (>= 9) but 8.4.0-1ubuntu1~18.04 is to be installed
             Depends: libusb-1.0-0 (>= 2:1.0.22) but 2:1.0.21-2 is to be installed
E: Unable to correct problems, you have held broken packages.

Πιθανον δεν ειναι για αυτην την εκδοση.
Το Zorin 15.03 δεν ειναι βαση του ubuntu 20.04;

Όχι είναι βασισμένο στο Ubuntu 18.04.

Τα σφάλματα που σου βγάζει αυτό κενέ ότι ψάχνουν νεότερες έκδοσης βιβλιοθηκών και δεν τις βρίσκει όποτε μάλλον θα πρέπει να δεις μήπως έχουν στο site τους κάποιο πακέτο συμβατό με Ubuntu 18.04

Ναι, σου το λέει ότι βασίζεται στον πυρήνα Linux 5.4 που είναι διαθέσιμος και στον 20.04. Αυτό σε καμία περίπτωση δεν σημαίνει ότι βασίζεται στο Ubuntu 20.04.

Οι διανομές Linux δεν είναι ενιαίο σύστημα αλλά αποτελείται από διάφορα τμήματα τα οποία μπορείς να αλλάζεις σε κάποιο βαθμό. Δες :

Άρα για το πρόβλημα σου η λύση είναι μια απο τις παρακάτω:

  1. Βάζεις Ubuntu 20.04
  2. Βάζεις διανομή βασισμένη στο Ubuntu 20.04
  3. Κρατάς το Zorin 15 και ψάχνεις drivers για 18.04
2 Likes

Αυτό το νήμα έκλεισε αυτόματα 2 ημέρες μετά την τελευταία απάντηση. Δεν επιτρέπονται πλέον νέες απαντήσεις.