Προβλημα με σύνδεση L2TP VPN στον network manager

Καλημέρα σε όλους, εδω ειμαι ξανά με ένα ξαφνικό πρόβλημά μου που παρουσιαστηκε ενω όλα λειτουργούσαν κανονικά, το μονο που μπορώ να φανταστω ειναι οτι καποιο Update να πειραξε κατι και απο τότε όχι μονο δεν μπορει να συνδεθει σε κανενα απο τα ήδη υπάρχοντα VPN προφίλ, αλλα δεν μπορώ ουτε να δημιουργήσω καποιο νέο, διότι δεν εμφανίζονται οι ρυθμίσεις που χρειάζονται στο μενού “ταυτότητα”, οπως σας δειχνω και στο screen παρακάτω, επισεις φαινονται και οι εντολές που ειχα χρησιμοποιείσει για το instalation του L2tp .


Οποια βοήθεια ευπρόσδεκτη.
Και μην μου αρχίσετε ξανα , γιατι δεν βαζεις αλλο τυπο VPN ή άλλα… Το L2TP δούλευε και πρεπει να συνεχίσει να δουλεύει. Ευχαριστω.

Έκδοση Mint? Έκδοση πυρήνα? Έκδοση network-manager-l2tp?
Το πρόβλημα σου είναι αυτό :

Συνοψίζεται σε αυτήν την παράγραφο :

the VPN plugins contain a GTK(3) UI part which is used by gnome-control-center (packaged in “NetworkManager-{openvpn,openconnect,…}-gnome” packages).

Those GTK parts currently only exist in a GTK3 version, although there is work in progress to also build (and install) a GTK4 version.

An application cannot both load GTK3 and GTK4 at the same time. That means, if you build gnome-control-center against GTK4, then you’ll also need GTK4 plugins – which don’t exist yet.
The fix is, to port all VPN plugins to GTK4 (in addition to GTK3). This is work in progress.

διάβασε καλά εδώ :
https://bugzilla.redhat.com/show_bug.cgi?id=2057719

Για να το πούμε και στα ελληνικά, υπάρχουν GTK3 στοιχεία στα plugins, που δεν έγιναν ported στο GTK4, έτσι με την αναβάθμιση του gnome-control-center (το οποίο χρησιμοποιεί GTK4), υπάρχει πρόβλημα στο dialog-box.

2 «Μου αρέσει»

Αντιμετώπισα το ίδιο πρόβλημα @Anthemous.
Ευχαριστούμε @Maras για την άμεση ενημέρωση.
Υπάρχει λύση που να λειτουργεί με l2tp σε gtk4;

1 «Μου αρέσει»

@nikaskonstantinos, σου απαντάω μέσω του δημιουργού :

You can’t edit L2TP connections at the moment with Gtk4 based gnome-control-center (only with Gtk3 based nm-connection-editor), it’ll be fixed once they update the network-manager-l2tp package from version 1.20.0 to 1.20.2 that includes Gtk4 support.

Δείτε εδώ το github του plugin :

Θα διορθωθεί όταν οι διανομές πακετάρουν την έκδοση : 1.20.2 και μεταγενέστερες.
Δοκιμάστε να build-αρετε την εφαρμογή από source, καθώς τώρα είναι στην 1.20.4.

2 «Μου αρέσει»

System: Kernel: 5.13.0-27-generic x86_64 bits: 64 compiler: N/A Desktop: Cinnamon 5.2.7
wm: muffin dm: LightDM Distro: Linux Mint 20.3 Una base: Ubuntu 20.04 focal
Machine: Type: Laptop System: LENOVO product: 8OR6 v: Lenovo Flex 3-1580 serial:
Chassis: type: 10 v: YOGA500-15ISK serial:
Mobo: LENOVO model: YOGA500-15ISK v: SDK0K17763 WIN serial: UEFI: LENOVO
v: D3CN39WW date: 06/26/2018

Πηγα στο Github και κατεβασα το νεο .zip αλλά δεν το καταφερα να το Build-άρο :)
Εχει το “autogen.sh” και το “configure.ac” , αλλά δεν εγιναν εγγατάσταση, μηπως καποιος , τις εντολές ; για να ξαναδοκιμάσω να Build-άρω ? :D many thanks.
EDIT, μετά από μια ώρα , ψαχνωντας διάφορα… ανακάλυψα ότ ανοίγωντας, το " Advanced Network Configuration", μπόρεσα και δημιούργησα ξανά το προφιλ για την συγκεκριμένη σύνδεση και οχι μονο, αλλά συνδέθηκε κανονικά! (ισως επαιξε κανενα ρολο καποια απο τις προσπάθεις που εκανα να περασω manual το Build που ειπε ο Maras, δεν ξερω… αλλά τωρα δουλεύει, απλά απο το “Δυκτιο” εξακολουθεί να μην μπορεί να κανει Edit και Add ,νεο προφίλ , αλλα συνδέεται σε αυτο που δημιούργησα μεσω “Advanced” .
Ολα καλά λοιπόν και απλά περιμενω το Updade για να δουλέψει και κανονικά.
Ευχαριστω

1 «Μου αρέσει»

Σύμφωνα με τις οδηγίες του δημιουργού για να χτιστεί το λογισμικό σε Debian 11 και Ubuntu 22.04, από τον πηγιαίο κώδικα, χρειάζεται να το κατεβάσουμε από εδώ (έκδοση 1.20.4), να το αποσυμπιέσουμε, να μεταβούμε με τερματικό μέσα στον φάκελο που δημιουργείται και να δώσουμε τις 3 εντολές με την σειρά :

./autogen.sh
./configure \
  --disable-static --prefix=/usr \
  --sysconfdir=/etc --libdir=/usr/lib/x86_64-linux-gnu \
  --libexecdir=/usr/lib/NetworkManager \
  --runstatedir=/run \
  --with-pppd-plugin-dir=/usr/lib/pppd/2.4.9 

και

make

και αφού χτιστεί για να το εγκαταστήσουμε δίνουμε :

sudo make install
2 «Μου αρέσει»

Χρειάζονται και κάποια
προαπαιτούμενα
Πάλι όμως λαμβάνω μηνύματα λάθους.

1 «Μου αρέσει»

Σωστά, τι μηνύματα σου βγάζει?

1 «Μου αρέσει»

Καλησπέρα @Maras ευχαριστούμε για τη βοήθεια.
Το λάθος

Can't exec "autopoint": No such file or directory at /usr/share/au
toconf/Autom4te/FileUtils.pm line 293.                            
autoreconf: error: autopoint failed with exit status: 2 

εμφανίζεται παρακάτω:

asciicast

1 «Μου αρέσει»

Εγκατέστησε το autoconf και ξαναδοκίμασε.

1 «Μου αρέσει»

@Maras για άλλη μια φορά έχετε τη λύση! :white_check_mark:
Είχατε δίκιο, δεν είχα εγκατεστημένο το autoconf και το autopoint.

Έτοιμο και με το κλειδί στο χέρι το l2tVPN-Network-Manager πρόσθετο στην έκδοση Pop!_Os 22.04.

Συνοψίζοντας έπρεπε να εκτελέσω με sudo τις παραπάνω εντολές, αφού πρώτα έχω εγκαταστήσει το autoconf και το autopoint, με:
sudo apt install autoconf autopoint

Ευχαριστούμε πολύ.

Σημείωση προς τους διαχειριστές.
Δεν έχω την επιλογή να επιλέξω Λύση, σε αυτή την κατηγορία.
Μπορείτε να το κάνετε εσείς;
Ο @Maras μας βοήθησε πολύ.

2 «Μου αρέσει»