Ath10k_pci αδυναμία σύνδεσης σε wifi

Καλησπέρα,

κάποιες φορές με την εκκίνηση του συστήματος δεν μπορώ να συνδεθώ στο wifi. Παρά το ότι “βλέπει” το ssid, δείχνει να προσπαθεί να συνδεθεί αλλά εν τέλει δεν συνδέεται. Μετά από επανεκκίνηση επιτυγχάνεται σύνδεση.

journalctl -p -3 -xb
outputs:
ath10k_pci 0000:03:00.0: Could not init core: -110

lspci | grep -i network
outputs:
03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

Πρόσθεσε την παράμμετρο pcie_aspm=off στον GRUB, κάνε update τον GRUB και δες αν παραμένει το πρόβλημα.

Καλημέρα και ευχαριστώ για την απάντηση.

το έκανα ως εξής:
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet pcie_aspm=off"

κι έπειτα
sudo grub-mkconfig -o /boot/grub/grub.cfg

Θα το δουλέψω σήμερα με αυτές τις ρυθμίσεις και θα επανέλθω…

1 Like

Αν δουλέψει αυτή η μέθοδος μην ξεχάσεις να μαρκάρεις τη λύση για να θεωρηθεί λυμένο.

Εννοείται πως θα το κάνω όπως και σε προηγούμενες αναρτήσεις.

Δυστυχώς, αν και η αναζήτηση για αυτήν την λύση ήταν καλή αφορμή για ενημέρωση, δεν έλυσε το πρόβλημα.
Πάλι σήμερα σε κάποιαν επανεκκίνηση υπήρχε αδυναμία σύνδεσης στο wifi. Ενώ το εντοπίζει και δείχνει πως προσπαθεί να συνδεθεί (το βλέπω wifi settings) τελικά δεν έχω σύνδεση. Έπρεπε να κάνω reboot για να τα καταφέρω.

Επανέρχομαι μετά από καιρό αφού περιστασιακά συμβαίνει (σχεδόν το έχω συνηθίσει!)

Κάποιες φορές όταν δεν μπορώ να συνδεθώ και κάνω επανεκκίνηση, όταν κλείνει το γραφικό περιβάλλον προλαβαίνω να δω για ελάχιστα δευτερόλεπτα το εξής μήνυμα:
Failed to start Network Manager wait online

Άλλη φορά το
journalctl -p -3 -xb
βγάζει:

kernel: ath10k_pci 0000:03:00.0: Could not init core: -110
Failed to start Network Manager wait online
A start job for unit NetworkManager-wait-online.service has failed

Τα αναφέρω γιατί στο αρχικό μου μήνυμα δεν υπήρχαν στο log και αναρωτιέμαι μήπως πρέπει να το κάνω disable.