Ρύθμιση ευαισθησίας ποντικιού / Ταχύτητας δείκτη

Έχω ένα πρόβλημα με την ευαισθησία του ποντικιού σε Ubuntu 20.04 LTS, ο δείκτης κινείται πολύ γρήγορα.

Το mouse είναι ένα Logitech G400s Optical Gaming Mouse και το όλο ζήτημα το έχω συναντήσει και σε Ubuntu 18.04 LTS με αντίστοιχα ποντίκια με υψηλό dpi.

Προσπαθώντας να ρυθμισω το ποντίκι ακολουθώντας τις αναφορές:


βρήκα τη συσκευή (id=9)


# xinput --list --short
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech G400s Optical Gaming Mouse     	id=9	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Eee PC WMI hotkeys                      	id=10	[slave  keyboard (3)]
    ↳ CHICONY HP Basic USB Keyboard           	id=8	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]

και τις διαθέσιμες ρυθμίσεις:

# xinput --list-props 9
Device 'Logitech G400s Optical Gaming Mouse':
	Device Enabled (153):	1
	Coordinate Transformation Matrix (155):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Natural Scrolling Enabled (287):	0
	libinput Natural Scrolling Enabled Default (288):	0
	libinput Scroll Methods Available (289):	0, 0, 1
	libinput Scroll Method Enabled (290):	0, 0, 0
	libinput Scroll Method Enabled Default (291):	0, 0, 0
	libinput Button Scrolling Button (292):	2
	libinput Button Scrolling Button Default (293):	2
	libinput Middle Emulation Enabled (294):	0
	libinput Middle Emulation Enabled Default (295):	0
	libinput Accel Speed (296):	-1.000000
	libinput Accel Speed Default (297):	0.000000
	libinput Accel Profiles Available (298):	1, 1
	libinput Accel Profile Enabled (299):	1, 0
	libinput Accel Profile Enabled Default (300):	1, 0
	libinput Left Handed Enabled (301):	0
	libinput Left Handed Enabled Default (302):	0
	libinput Send Events Modes Available (272):	1, 0
	libinput Send Events Mode Enabled (273):	0, 0
	libinput Send Events Mode Enabled Default (274):	0, 0
	Device Node (275):	"/dev/input/event3"
	Device Product ID (276):	1133, 49740
	libinput Drag Lock Buttons (303):	<no items>
	libinput Horizontal Scroll Enabled (304):	1

Έπειτα έφτιαξα το παρακάτω bash script και το ονόμασα set-mouse:

# cat /usr/local/sbin/set-mouse 
#!/bin/sh
xinput --set-prop 9 296 -1

και το ρύθμισα να εκτελείται κατά την εκκίνηση.

Η κατάσταση βελτιώθηκε, ωστόσο όμως υπάρχουν ζητήματα.

  1. Εάν ο υπολογιστής βρεθεί σε αδράνεια και μεταβεί σε suspend mode, έπειτα κατά την επαναφορά ο δείκτης απορυθμίζεται και θέλει πάλι να τρέξω το bash script.

  2. Παρότι την παραπάνω ρύθμιση, θα επιθυμούσα ο δείκτης να κινείται ακόμη πιο αργά.

Ερωτήσεις:

  1. Έχετε να προτείνετε κάποια πιο μόνιμη λύση?

  2. Μπορεί να υπάρχει κάποια άλλη ρύθμιση της συσκευής (που να μην έχω κάνει) και να βοηθήσει την κατάσταση?

Σας ευχαριστώ για το χρόνο σας!

Σωτήρης

3 Likes

Δες μήπως το solaar ή το piper έχουν κάποια γνώση για το συγκεκριμένο ποντίκι. Δοκίμασε να μειώσεις τα dpi.

Μπορείς να βάλεις το script που έφτιαξες να τρέχει μέσα από το udev

# cat /etc/udev/rules.d/LogitechFastMouse.rules
ACTION=="add", ATTRS{vendor}=="...", ATTRS{model}=="..", , RUN+="/pathto/script"

Μετά που θα πειράξεις τους κανόνες του udev θα πρέπει να δώσεις

udevadm control --reload-rules && udevadm trigger
2 Likes

Καλώς ήρθες @condor0s στην παρέα μας :hugs:

1 Like

Σε ευχαριστώ πολύ Γιάννη!

Καλώς σας βρήκα Βασίλιε!

1 Like