Προβλήματα με την πρόσβαση σε διάφορες ιστοσελίδες

Εδώ και περίπου 1 μήνα έχω πολύ συχνά προβλήματα πρόσβασης σε διάφορες ιστοσελίδες(κάποιες φορές και στο παρόν φόρουμ). Αυτό συμβαίνει σε archlinux και εκτός από τις σελίδες συμβαίνει και στις ενημερώσεις. Χρησιμοποιώ το pamac και ακρετές φορές αποτυγχάνουν(λόγω αποτυχίας λήψης) ή καθυστερεί πάρα πολύ να γίνει η ενημέρωση των αποθετηρίων και η λήψη των πακέτων. Πολύ συχνότερα υπάρχει πρόβλημα με το aur, όπου το pamac στην αναζήτηση δε βρίσκει καν το πακέτο ενώ υπάρχει, ενώ η εγκατάσταση αποτυγχάνει λόγω αποτυχίας λήψης(κυρίως απ’ το github). Αν προσπαθήσω να μπω στη σελίδα του aur όταν συμβαίνει το παραπάνω, δε μπορώ και βγαίνει το σφάλμα ότι δε βρέθηκε η σελίδα. Το περίεργο είναι(πράγμα που μάλλον δείχνει ότι δεν είναι θέμα archlinux, αλλά ίσως γενικότερο) ότι αν προσπαθήσω να μπω στη σελίδα αυτή από συσκευή android μπαίνω χωρίς πρόβλημα και μετά από αυτό μπορώ να μπω στη σελίδα επίσης χωρίς πρόβλημα και στο arch.
Δοκίμασα να αλλάξω τον οδηγό για την κάρτα δικτύου από r8169 στον r8168, μιας και αυτός φαίνεται ότι είναι για την κάρτα. Για μερικές ώρες δεν είχα πρόβλημα οπότε νόμιζα ότι λύθηκε, αλλά την επόμενη μέρα ξανάρχισαν τα ίδια και με τον r8168.
Επίσης δοκίμασα να απενεργοποιήσω την ethernet συνδέση(για την περίπτωση που έχει θέμα το ethernet καλώδιο) και να χρησιμοποιήσω έναν tp-link wifi adapter για μια μέρα, αλλά και μ’ αυτόν είχα το ίδιο πρόβλημα.
Στη σελίδα του router δε φαίνεται να υπάρχει κάποιο πρόβλημα. Το μόνο που δεν δοκίμασα ακόμη είναι ν’ αλλάξω dns server μιας και χρησιμοποιώ opendns το τελευταίο 6μηνο.
Καμιά ιδέα? Σώζεται η κατάσταση ή μήπως είναι απλά θέμα φόρτου γραμμής? Αυτό βέβαια δεν εξηγεί το γεγονός ότι ξεμπλοκάρει όταν γίνει πρόσβαση από συσκευή android.

Δοκίμασε να απενεργοποιήσεις το IPv6 από το linux.

4 Likes

Ευχαριστώ.
Το απενεργοποίησα στο connman που χρησιμοποιώ, αλλά και στις ρυθμίσεις του router μιας και το είχα ενεργοποιήσει πριν μερικούς μήνες. Τώρα μένει να δοκιμαστεί για λίγο αν δούμε αν έχει κάποιο αποτέλεσμα

Έχω ένα VirtualBox με περίπου 35 διανομές linux (+MacOS, +Windows 10 & Servers διαφόρων εκδόσεων) + ένα mini PC με Ubuntu 20.04. Σχεδόν όλες οι διανομές linux κατά καιρούς μου παρουσίαζαν το πρόβλημα που προ ανέφερες, και κάποια στιγμή το παρατήρησα και σε στα VMs με Windows. Και όλα είχαν ενεργοποιημένο το IPv6 στο δίκτυο. Όταν το απενεργοποιούσα συνήθως το πρόβλημα εξαφανιζόταν.


Γενικά τo IPv6 στην Ελλάδα έχω την εντύπωση ότι έχει προβλήματα. Δεν έχω μεγάλη εμπειρία με την συγκεκριμένη έκδοση του IP πρωτοκόλλου αλλά σε VPS, Cloud Servers ή απλό Webhosting που το δοκίμασα (και ήταν hosting σε datacenters στην Ελλάδα), είχα συνήθως πρόβλημα.

Επίσης στις διανομές linux σε VMs έχω παρατηρήσει σε κάποιες από αυτές μία καθυστέρηση στο DNS. Δηλαδή , άνοιγα τον firefox ή το chrome για να μπω στο https://linux-user.gr και έκανε 2-3 δευτερόλεπτα να εμφανίσει το site… αλλά από εκεί και μετά η πλοήγηση μέσα στο site ήταν σχετικά γρήγορη. Το πρόβλημα της καθυστέρησης λύθηκε αλλάζοντας της ρυθμίσεις στο IPv4 της εκάστοτε διανομής ορίζοντας ποιο DNS server θα χρησιμοποιώ μέσα από τις ρυθμίσεις της κάρτα δικτύου… για να μην παίρνει αυτόματα τον DNS server από το router μου!
image

2 Likes

Μέχρι στιγμής όλα είναι εντάξει, οπότε φαίνεται πως αυτό ήταν το πρόβλημα. Το IpV6 το είχα απενεργοποιημένο στο ρουτερ εδώ και χρόνια μιας και είχα καθημερινό πρόβλημα αποσυνδέσεων. Τελικά πριν 4-5 μήνες λόγω του ότι το πρόβλημα αυτό χειροτέρεψε με αποτέλεσμα να μου ρίξουν την ταχύτητα της γραμμής, άλλαξα το spliter και την πρίζα σύνδεσης του εξωτερικού καλωδίου και αφού το πρόβλημα λύθηκε ζήτησα να επανέλθει η ταχύτητα εκεί που ήταν. Μετά από κανένα μήνα και αφού όλα λειτουργούσαν κανονικά ενεργοποίησα το IPv6 στο ρούτερ. Μέχρι πριν ενα μήνα όλα ήταν εντάξει και γι’ αυτό δεν περίμενα να ευθύνεται. Φαίνεται τελικά όμως ότι αυτό ήταν.

1 Like

Προβλήματα στο internet όταν είναι ενεργοποιημένο το IPv6 στο router έχει παρατηρηθεί σε συνδέσεις internet όπου ο πάροχος δρομολογεί το internet του χρήστη μέσω Carrier-grade NAT (CGN)… δες στο blog μου “Μήπως η public IP που δείχνει το router σας (100.xxx.xxx.xxx) είναι διαφορετική από την πραγματική pubic IP?

3 Likes