Πρόβλημα με το Alt-Shift στον Opera

καλημερα εχω ενα θεμα εχω ubuntu 19.04 και εχω opera browser καθε φορα που παταω alt+shift μου βγαζει μενου γνωριζει κανεις πως το απενεργοποιουμε?

Σε γενικές γραμμές το Alt δείχνει το κρυμμένο μενού μιας εφαρμογής. Οπότε είναι θέμα χρονισμού. Υπάρχει ένας απλός τρόπος αντί για AltShift, δοκίμασε με ShiftAlt :smile:

Μια καλή ιδέα είναι να χρησιμοποιήσεις κάτι άλλο για αλλαγή γλώσσας. Εδώ θα βρεις πως θα το κάνεις στο :mint:, αλλά δεν αλλάζει πολύ ο τρόπος για το :ubuntu:. Προτείνω να δοκιμάσεις το Caps Lock

Στο keybord tag θα βρεις πολλά άλλα κόλπα

Συγγνώμη για την άχρηστη απάντηση :stuck_out_tongue: αλλά δεν κατάλαβα είναι μετού τής opera ή τού gnome;
Αν είναι το πρώτο δεν ξέρω γιατί δεν χρησιμοποιώ opera αλλά έκανα μια δοκιμή από περιέργεια και δεν μού βγάζει κάποιο μενού. Αν είναι το δεύτερο δεν ξέρω γιατί δεν χρησιμοποιώ gnome. Τέλος λέω και εγώ βάλε το Caps Lock που πρότεινε και ο Talos.

TALOS με το shift+alt μια χαρα πετυχαινει δεν βγαζει το μενου πως μπορω να το αλλαξω δεν με βολευει αναποδα εχω συνηθισει με alt+shift

Όταν λες “μου βγάζει μενού” τι εννοείς? Τι μενού σου βγάζει?

Μήπως να έβαζες ένα screenshot, για να καταλάβουμε καλύτερα?

2 Likes

Μπορείς να δεις αν έχει την ίδια συμπεριφορά και στον firefox ?

οχι δεν εχει μονο στο opera

1 Like

Το πάθαινα και εγώ αυτό πολλές φορές…ήταν πραγματικά εκνευριστικό…πλέον το γύρισα στο brave και ησύχασα :wink:

Στον Firefox αν το μενού είναι κρυμμένο (Δεξί κλίκ ->Ξετικαρισμένο Menu Bar (Μπάρα μενού)) με το alt εμφανίζεται. Αν είναι τικαρισμένο τότε δεν έχει κάποιο αποτέλεσμα το alt. Αυτό ισχύει και στα Windows βέβαια. Θα πρότεινα μία αλλαγή στο κλασικό Super + Space των Linux. Εμένα μου πήρε περίπου ένα μήνα να το συνηθίσω.

1 Like

Στον Opera, η προεπιλεγμένη συμπεριφορά στο άφημα του πλήκτρου Alt είναι να εμφανίζει το μενού του Opera.
Σύμφωνα με το διαδίκτυο εδώ και πολλά χρόνια οι χρήστες του Opera προσπαθούν να πείσουν τους προγραμματιστές του να αλλάξουν αυτή την συμπεριφορά ή έστω να τους δώσουν την δυνατότητα να αλλάξουν τον συνδυασμό αλλά μάταια.

Από το 2010: How to disable Opera alt button?
Από το 2013: Alt key opens menu
Από το 2014: How to disable Opera menu being open by pressing alt in opera 20+
Από το 2015: Disable Alt Key Drop-down Menu
Από το 2015: Anyway to hide or move the “Menu” drop-down list in the top left hand corner?
Από το 2017: Left alt key - dropdown menu
Από το 2018: Option to turn off ALT key opening main menu

Η καλύτερη λύση, εφόσον θέλεις να κρατήσεις τον Opera, είναι να μάθεις σε άλλο συνδυασμό πλήκτρων εναλλαγής γλώσσας, όπως προείπαν και τα παιδιά παραπάνω, όπως το Caps Lock. Θα σου πάρει χρόνο αλλά είναι αρκετά παραγωγικότερο, ένα πλήκτρο άρα και ένα πάτημα λιγότερο, και πιο γρήγορο. Ίσως το μόνο μειονέκτημα είναι πως αν δουλεύεις και Παράθυρα ταυτόχρονα, θα πρέπει να μάθεις και στα δύο, γιατί τα Παράθυρα δεν έχουν ενσωματωμένο τρόπο να αλλάξεις τον συνδυασμό πλήκτρων εναλλαγής γλώσσας και θα πρέπει να εγκαταστήσεις τρίτου μέρους πρόγραμμα κάτι που προσωπικά απεχθάνομαι.

2 Likes

constantine πως κανω εγκατασταση το brave?

Αν χρειαστείς περισσότερη βοήθεια, ή άνοιξε νέο νήμα για να σε βοηθήσουμε ή απάντα στο ήδη υπάρχον νήμα με λεπτομέρειες του προβλήματός σου.

2 Likes

δηλαδη δεν εχω καμια ελπιδα να την αλλαξω θα συμβιβαστώ με shift+alt?

1 Like

Πάντως μόλις δοκίμασα να δω τι συμβαίνει σε μένα (σε arch linux). Αλλάζω γλώσσα με alt+shift όσο είμαι μέσα σε opera χωρίς κανένα θέμα (δεν ανοίγουν μενού κτλ)…

Όπως είπα παραπάνω και σε μένα το ίδιο, τίποτα. Το θέμα πρέπει να σχετίζεται και με το Gnome μάλλον, αλλά δεν υπάρχει περίπτωση να αγγίξω Gnome ούτε για αστείο.

By the way, κι εγώ δεν έχω gnome - έχω cinnamon… Φαντάζομαι όμως ότι αν είχε σχέση με το gnome, θα έπρεπε να το κάνει σε όλα τα προγράμματα και όχι μόνο στην opera…

Υποτιμάς το Gnome *******************