Πρόβλημα με ήχο μετά από εγκατάσταση

Καλησπέρα σε όλους είμαι καινούργιος στο Linux και αντιμετωπίζω το εξής πρόβλημα:
Στο laptop μου μετά από εγκατάσταση του Μint 20. ο ήχος δεν παίζει…
Έκανα εγκτατασταση την εφαρμογή Pulse Audio. Στη καρτέλα συσκευές εξόδου μου δίνει 2 επιλογές

  1. Headphones (Pluggen in)
  2. Mono Speaker (unplugged).
    Εαν επιλέξω to 2 τότε ο ηχος ακούγεται κανονικά απ ολες τις εφαμογες αν ομως κανω επανεκινηση τον υπολογστη τοτε δεν ηχο και πρεπει και παλι χειροκινητα να αλλαξω την εξοδο ηχου…
    Υπαρχει τροπος ετσι ωστε να μενει μονιμα η επιλογη 2 και να ξεκιναει ο ηχος αυτοματα? Ευχαριστω πολυ…

Τα χαρακτηριστικα τoυ laptop ειναι αυτα:

System:
Host: antonis-GTN1408 Kernel: 5.4.0-66-generic x86_64 bits: 64
Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana
Machine:
Type: Desktop System: Info Quest product: GTN1408 v: N/A
serial: <superuser/root required>
Mobo: Info Quest model: GTN1408 serial: <superuser/root required>
UEFI: American Megatrends v: N1408TQD.C3D3LW.INFOQUEST.G001.2017.0304.1105
date: 03/04/2017
Audio:
Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series
Imaging Unit
driver: intel_atomisp2_pm
Sound Server: ALSA v: k5.4.0-66-generic

Αυτό το (unplugged) είναι προβληματικό. Υπάρχει ένα εργαλείο το hdajackretask που αλλάζει το νόημα που έχουν τα βύσματα της κάρτας ήχου. Θα το βρεις στις Debian διανομές μέσα στο πακέτο alsa-tools-gui και ίσως βοηθήσει.

Ένα εναλλακτικό εδώ HDA Analyzer - AlsaProject

Εκανα το hdajackretask εγκατασταση και μ ανοιξε αυτο το παραθυρο τι αλλαγες να κανω?

Δεν βλέπει τα βύσματα, μια τυπική περίπτωση που συμβαίνει αυτό είναι αν χρησιμοποιείς μια εξωτερική κάρτα ήχου μέσω usb/bluetooth. Δώσε μας πληροφορίες για το πως συνδέεις τον ήχο. Γιατί λέει monο και όχι στέρεο; Ακούς και απο τα δύο ηχεία; Με τα ακουστικά δουλεύει; Δώσε το αποτέλεσμα της εντολής aplay -l και της εντολής amixer.

Και επειδή το ξέχασα πριν: Καλώς ήρθες @ntontos1984 στο linux-user.gr :slight_smile:

Καλως σας βρηκα!!! και ευχαριστω για την αμεση ανταποκριση… Τα ηχεια ειναι τα ενσωματωμενα του λαπτοπ… Οταν στο pulse audio επιλεξω το mono τοτε δουλευουν κανονικα τα ηχεια και τα 2… μεχρι το επομενο reboot φυσικα… Τα ακουστικα δουλευουν κανονικα απο την αρχη δεν εχουν θεμα και το ΗDMI

τα αποτελεσματατα ειναι αυτα:

*** List of PLAYBACK Hardware Devices ****
κάρτα 0: Audio [Intel HDMI/DP LPE Audio], συσκευή 0: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Υποσυσκευές: 1/1
  Υποσυσκευή #0: subdevice #0
κάρτα 0: Audio [Intel HDMI/DP LPE Audio], συσκευή 1: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Υποσυσκευές: 1/1
  Υποσυσκευή #0: subdevice #0
κάρτα 0: Audio [Intel HDMI/DP LPE Audio], συσκευή 2: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Υποσυσκευές: 1/1
  Υποσυσκευή #0: subdevice #0
κάρτα 1: bytchtes8316 [bytcht-es8316], συσκευή 0: 1 []
  Υποσυσκευές: 1/1
  Υποσυσκευή #0: subdevice #0
κάρτα 1: bytchtes8316 [bytcht-es8316], συσκευή 1: Deep-Buffer Audio (*) []
  Υποσυσκευές: 1/1
  Υποσυσκευή #0: subdevice #0

Αυτες τις επιλογες μ βγαζει

Το ότι δεν έχεις ήχο μετά από επανεκκίνηση οφείλεται στο είναι επιλεγμένη η πρώτη συσκευή που βλέπει το σύστημα ως default για τον ήχο και όχι αυτή που θέλεις εσύ. Θα πρέπει λοιπόν να την επιλέξεις. Στο mint νομίζω στις ρυθμίσεις για τον ήχο, στις συσκευές εξόδου έχει μια επιλογή να θέσεις τη συσκευή που θέλεις ως fallback(set as fallback). Αυτό σημαίνει ότι τη θέτεις ως προεπιλεγμένη συσκευή για τον ήχο.
Edit:
Είναι το τελευταίο εικονίδιο δεξιά.

Ευχαριστω πολυ για την απαντηση σου αυτο το πραγμα προσπαθω να κανω αλλα δεν βρισκω τετοια επιλογη μεσα στο mint πιθανον να γινεται με καποια εντολη αλλα δεν ξερω με ποια…

Στην καρτελα Configuration τι έχει?

Δεν έχω ξαναδεί αυτό το configuration, αλλά μια πιθανή λύση θα βρεις στα παρακάτω link. Αποθήκευσε πρώτα κάπου το αρχικό αρχείο /usr/share/pulseaudio/alsa-mixer/paths/analog-output-lineout.conf. Τις αλλαγές θα πρέπει να τις κάνεις με sudo

cd /usr/share/pulseaudio/alsa-mixer/paths
sudo cp analog-output-lineout.conf analog-output-lineout.conf-backup
sudo gedit analog-output-lineout.conf

PulseAudio sane headphone/lineout switching · GitHub

sound - How to switch between headphones and speakers without unplugging headphones - Ask Ubuntu

PulseAudio headphone jack troubles : A Weird Imagination

No sound from headphones fixed - Linux Mint Forums

Εχει αυτες τις 2 επιλογες η πανω π ειναι ανεγεργη δινει για ηχο 5.1 και λει δεν ειναι δαθεσιμη

Στην ενεργή δες τις επιλογές που έχει στο profile, δοκίμασε να αλλάξεις αυτή που έχει με τις άλλες διαθέσιμες μήπως είσαι σε λάθος προφίλ

Επίσης δοκίμασε με το pavucontrol. Παρέχει περισσότερες επιλογές. Θα πρέπει να το εγκαταστήσεις πρώτα.

1 Like

Αλλαξα τα παντα και δεν εχω καμια διαφορα

Με την εντολη alsa mixer μου βγαζει 2 καρτες στη 1η δεν μ δινει καμια επιλογη στη 2η μ δινει την δυνατοτητα κανω αλλαγες ενεργοποιω τα ηχεια και παζει κανονικα … οταν ομως κανω επανεκινηση εχω παλι το ιδιο θεμαΣτιγμιότυπο από 2021-03-12 21-11-35

πως κανω εγκατασταση των δυνατοτητων του pavucontrol???

Το εγκαθιστάς με την εντολή :

sudo apt install pavucontrol

To εχω ηδη εγκατεστημενο απο εκει κανω την αλλαγη χειροκινητα το θεμα ειναι να βρεθει τροπος να γινει προεπιλογη το σαν επιλογη εξοδου το mono speaker εχω βαλει εικονα σε προηγουμενη μ απαντηση

Δώσε λίγο το αποτέλεσμα της εντολής :

cat /proc/asound/cards

καλως ηρθες @ntontos1984
διαβασε αυτο εδω → PulseAudio, Pavucontrol not saving settings after reboot on Ubuntu and Ubuntu based distributions, Ubuntu
και αν εχεις αποριες ρωτα…
μια καλη πρακτικη γενικα ειναι πριν πειραξουμε αρχεια, να κραταμε αντιγραφα των αρχικων αρχειων πρωτα

0 [Audio          ]: HdmiLpeAudio - Intel HDMI/DP LPE Audio
                      Intel HDMI/DP LPE Audio
 1 [bytchtes8316   ]: bytcht-es8316 - bytcht-es8316
                      bytcht-es8316-mono-spk-in1-mic

Δοκίμασε το εξής.
Φτιάξε ένα αρχείο με το όνομα :
.asoundrc
(να έχει και την τελεία μπροστά-θα είναι κρυφό έτσι) μέσα στον φάκελο home σου.
Τα περιεχόμενα του αρχείου να είναι οι παρακάτω 2 γραμμές :
defaults.pcm.card 1
defaults.ctl.card 1
Στην θέση του 1 θα βάλεις τον αριθμό της κάρτας που θέλεις να είναι default (έχεις 2 κάρτες όπως βλέπεις από τη προηγούμενή σου απάντηση με αριθμούς 0 και 1). Αφού θέλεις την 2η κάρτα, άσε τις γραμμές όπως είναι. Σώσε το αρχείο, κάνε επανεκκίνηση και πες μας αν δούλεψε.

1 Like

Για να ορίσεις το default sink κάνεις τα ακόλουθα.

pacmd list-sinks | grep -e 'name:' -e 'index:'

Στο αποτέλεσμα θα σου εμφανίσει τα sinks. Αυτό που έχει αστερίσκο (*) είναι το default.

Στο αρχείο /etc/pulse/default.pa προσθέτεις στο τέλος το ακόλουθο

set-default-sink το-όνομα-του-default-sink

Κάνεις reboot και τέλος.

Περισσότερα εδώ

Edit: Διόρθωσα το link. Ευχαριστώ @stefra για την υπόδειξη.

2 Likes