Login σε X11 αντί για Wayland

Καλησπέρα,
Όταν κάνω login στο gnome άλλοτε μπαίνει σε X11 και άλλοτε σε Wayland (που είναι το επιθυμητό). Όταν δεν μπαίνω σε Wayland έχω το μήνυμα:
Failed to start GNOME Shell on Wayland

journalctl -p 3 -xb outputs:
https://pastebin.com/1GgDL4G7

sudo journalctl -b outputs:
https://pastebin.com/Zz36hu2C

lscpi outputs:
https://pastebin.com/rawNHXRA

Ίσως είναι περιττό να πω πως είμαι καινούργιος στον χώρο του Archlinux

Δεν χρησιμοποιώ Gnome.

Έχω KDE με sddm. Ο sddm έχει ξεχωριστές επιλογές για KDE με wayland και KDE με x.org. Οπότε εκεί διαλέγω. Δεν ξέρω ποιο dm έχεις [ gdm? ] αλλά όπως το διαβάζω μοιάζει για παραξενιά τού dm στο να καλεί το gnome. Επίσης ενδεχομένως λείπουν βιβλιοθήκες; Μην περιμένεις πολύ βοήθεια για το πρόβλημα αλλά το κρίσιμο ερώτημα είναι πώς εγκατέστησες Arch; (και ειδικά το γραφικό περιβάλλον)

Το πιο κουλό είναι ότι λες

αυτό δεν μού φαίνεται πολύ λογικό (θα περίμενα όπως εγώ να έχεις ξεχωριστές επιλογές)

Απ’ ότι φαίνεται έχει σαν default τον Wayland, αλλά κάποιες φορές αποτυγχάνει το φόρτωμα και κάνει fallback σε X11, αυτό εννοεί ο φίλος αν κατάλαβα καλά.

@obaino έχεις παρατηρήσει κάποιο μοτίβο, πότε συμβαίνει? Μετά από χρήση κάποιου προγράμματος ή κάποιας ενέργειας, μετά ίσως από updates?

3 Likes

Καλημέρα και καλό μήνα.

Ευχαριστώ πολύ για τις απαντήσεις σας.

Ως dm έχω πράγματι τον gdm.
Εκεί όταν επιλέγω τον χρήστη που θα κάνει login υπάρχει η δυνατότητα να επιλέξω το session Gnome / Gnome Classic / Gnome on Xorg όπως φαίνεται στην εικόνα.
Όταν μπαίνω σε Wayland προεπιλεγμένη επιλογή είναι το Gnome.
Όταν μπαίνω σε X11 από τις επιλογές απουσιάζει το Gnome on Xorg, υπάρχουν μόνο το Gnome / Gnome Classic και καμία από τις δύο δεν εμφανίζεται ως προεπιλεγμένη.

Δυστυχώς δεν μπορώ να αναπαράγω κάποιες από τις δύο περιπτώσεις καθώς παρουσιάζονται τυχαία.

Κι εγώ κάτι τέτοιο πιστεύω πως συμβαίνει. Δεν γνωρίζω όμως πως να ψάξω για να εντοπίσω, ποια logs θα πρέπει να κοιτάξω.

Επανέρχομαι και πάλι στο θέμα που άνοιξα.
Διάβασα το παρακάτω σχετικά με το GDM στο archwiki:

Wayland requires Kernel Mode Setting (KMS) running in order to work, and on some machines the GDM process start earlier than KMS, resulting in GDM unable to see Wayland and working only with X.Org.

Προκειμένου να εκκινήσω το KMS πριν την έναρξη του GDM θα πρέπει να συμπεριλάβω i915 και amdgpu στο /etc/mkinitcpio.conf σύμφωνα με τις οδηγίες που διαβάζω εδώ.
Ερώτηση: αν κάνω edit το /etc/mkinitcpio.conf μετά τι εντολή τρέχω;
mkinitcpio -p linux ή κάτι άλλο… το διαβάζω εδώ αλλά δεν μου είναι ξεκάθαρο.

Ναι μετά τις τροποποιήσεις στο conf τρέχεις την εντολή που έγραψες.

Έκανα τις παραπάνω αλλαγές κι από τότε δεν έχω ξανακάνει login σε Χ11. Συνεπώς θα επισημάνω το νήμα ως solved.
Σας ευχαριστώ πολύ για τις απαντήσεις σας.