Linux πρόβλημα με wifi

Λοιπόν: έφυγα από τον ΟΤΕ. Έχω internet αλλά έχω κρατήσει το modem του ΟΤΕ με τις ίδιες ρυθμίσεις.

Ξαφνικά λοιπόν στον υπολογιστή δεν έχω internet μέσω wifi. Δηλαδή χρησιμοποιώ ένα TP-Link tl-wn722n για να πιάνω wifi από το modem μου. Οι θύρες usb κομπλέ με εξαίρεση οτι κάποιες φορές δεν τη βρίσκει κάποια θύρα αλλά αν αλλάξω τη βρίσκει. Αυτό τώρα το παρατήρησα.
Σε όλες τις θύρες λειτουργούν όλα τα mouse και external hdd που έχω.

Η διανομή είναι artix με cinnamon που το πρόβλημα είχα όταν πέρασα και το xfce iso (στην αρχή δεν το είχε και έκανε update). Το ίδιο πρόβλημα όμως έχει και το endeavourOS σε live usb.

Tα TP Link (έχω δύο ίδια) σε άλλο pc με linux mint δουλεύουν μια χαρά. Στο ίδιο pc που έχω mint είχα και artix με xfce και το έβγαλε και εκεί το πρόβλημα.

Επίσης δεν λειτουργεί ούτε το sudo rfkill list γιατί δε δίνει κάτι.
Δοκίμασα και με connman και με network manager.
Επίσης και με systemd και με runit / openrc.
To wifi είναι disabled σε ολες τις διανομές και δε λειτούργησε τίποτα.

lsusb και κλασσικά τα δοκίμασα όλα αλλά δεν δείχνουν να έχω κάνει κάτι λάθος.

Η μητρική δεν έχει θέμα γιατί αν ειχε τόσο καιρό που συνδεόμουν θα το είχα καταλάβει.

Καμιά ιδέα κανείς ?

Επειδή με μπέρδεψες… Με το modem έχεις επικοινωνία; Αν κάνεις ping την ΙΡ του, θα απαντήσει;
Γιατί αν απαντάει, αλλά συνεχίζεις να μη βλέπεις internet, πιθανότατα έχεις θέμα DNS.
Μήπως είχες καρφωτό κάποιο κι αλλάζοντας provider/modem δεν παίζει;

Όπως είπα χτες έβαλα το xfce και είχα internet. Αλλά και αυτό για λίγο κράτησε ( μια μέρα). Άρα ναι επικοινωνεί, γιατί αν δεν επικοινωνούσε πως είχα ?

Με αναζήτηση ούτε 5 λεπτών, σχετικό bug για το Artix και για το endeavourOS. Το κοινό των δύο bugs είναι ότι πρόκειται για τους ίδιους drivers (Broadcom). Ακόμα κι αν εσύ δεν έχεις αυτούς, βεβαιώσου ότι έχεις εγκατεστημένους αυτούς που χρειάζεται η κάρτα δικτύου σου.

1 Like

Άρα φίλε τι πρέπει να κάνω?
Σημείωση: αν ήταν αυτό γιατί προχτές είχα wifi?

Δώσε μας το output της εντολής
inxi -Fxd

Πρέπει να αρχίσεις να αποκλείεις πιθανές αιτίες του προβλήματος. Σου ανέφερα τους drivers γιατί από εκεί ξεκινούν όλα. ΑΝ αυτοί είναι εντάξει, μπορείς να πας παρακάτω.

Ούτε εγώ ούτε κάποιος άλλος στο forum έχουμε μαντικές ικανότητες. Την ερώτησή σου όμως μπορείς να την απαντήσεις μόνος σου, πολύ απλά, βρίσκοντας τι ήταν διαφορετικό στο σύστημά σου προχτές.

Υ.Γ. (μπορείς να το αγνοήσεις αλλά εγώ οφείλω να το αναφέρω): αν πελαγώνεις με τέτοια πράγματα και δεν ξέρεις τι να κάνεις, καλό θα ήταν να αποφύγεις τις δύο διανομές που ανέφερες.

1 Like

Να δημιουργήσεις τη δεξιότητα να ξετυλιγεις ένα πρόβλημα και ακόμη και αν δεν μπορείς να το λύσεις να φτάσεις στο σημείο να κατανοείς τι μπορεί να το προκαλεί.

Αυτό φυσικά δε γίνεται εν μια νυκτί και δεδομένου ότι διάλεξες διανομή που είναι arch based, πρέπει να προσέχεις δίπλα πριν κάνεις κάποιο update.

Έχει το δικαίωμα να παλέψει το πρόβλημα στο βαθμό που μπορεί.

5 Likes

Atheros Wireless καρτα δικτυου εχει

1 Like

Δυνατότητα ή ελευθερία είναι, όχι δικαίωμα, και φυσικά την έχει. Δεν του το απαγόρευσε κανένας αλλά, αντίθετα, του έδωσα κατεύθυνση για να ψάξει τη λύση. Η ερώτησή του όμως έχει όλα τα χαρακτηριστικά του τυπικού «δεν έχω ιδέα τι πάει στραβά, αναφέρω συγκεχυμένες πληροφορίες, δώστε μου λύση», που παραπέμπει σε άτομο το οποίο δεν έχει ακόμα την ικανότητα να διαχειριστεί μια τέτοια διανομή*, κάτι που εμμέσως πλην σαφώς του απάντησες κι εσύ παρακάτω.

Μερικές φορές το «tough love» λειτουργεί καλύτερα ως μέσο βελτίωσης από το διαρκές «hand-holding».


*(και για τον @rhtoras αυτό) Όσο κι αν επιμένουν να πλασάρονται ως «user-friendly», διανομές που βασίζονται σε «δεν πρόκειται ποτέ να γίνω user-friendly» διανομές, απλά μακιγιάρουν το υφέρπον σύστημα, δεν το εξαφανίζουν.

1 Like

σε ενα λαπτοπ που ειχα με την ιδια καρτα δικτυου με artix με το πακετο broadcom-wl δουλευε το wi-fi

2 Likes


To inxi -Fxd που επειδή δεν έχω ίντερνετ το έκανα έτσι.

Εχεις δοκιμάσει να βαλεις καλωδιο δικτυου και να κανεις μια αναβάθμιση ?

2 Likes

Όχι γιατί ειναι πάνω από 15 μέτρα η απόσταση.
Αν μεταφερω το PC γίνεται βέβαια αλλά προτιμώ το wifi…

Κατέβασε τότε το πακέτο που προτείνει ο @MetFM και εγκατέστησε το από τερματικό

1 Like

Αν εχεις android τηλεφωνο συνδεσε το με usb στον υπολογιστη και κανε φορητο σημειο προσβασης μεσω usb. Μετα και εφοσον θα εχεις ιντερνετ στον υπολογιστη, κανε ολες τις αναβαθμισεις.

Τωρα ειδα και το στικακι που χρησιμοποιεις. Νομιζω το ειχα και γω παλιοτερα και υπηρχε ενα σοβαρο προβλημα. Βγαινει σε v1, v2, v3 και εχει διαφορετικα chip. Νομιζω παλι οτι εχει ενα απο αυτα atheros αλλα οχι απο την κλασικη σειρα. Δεν εβαλες απ οτι ειδα και το lsusb για να εχουμε καλυτερη εικονα

edit - atheros zydas

2 Likes

Εχοντας βαλει το TP-LINK ανοιξε ενα τερματικο και να γραψεις: lsusb

Αυτο που παθαινεις μου ακουγεται περισσοτερο σαν προβλημα με το power management παρα σαν προβλημα με drivers. Δηλαδη υπαρχουν μερικες φορες που το TP-Link απλα δεν περνει ρευμα απο την USB θυρα στην οποια ειναι βυσματομενο.

  • Συμβαινει μετα απο suspend? ή συμβαινει ξαφνικα καθως εχει ο υπολογιστης Internet?
  • Εαν ο υπολογιστης ειναι σταθερος το TP-Link ειναι στα μπροστινα USB ή στα πισω;

Επισεις την επομενη φορα που μεινεις χωρις internet μπορεις επισεις στο ιδιο τερματικο που ανοιξες πιο πανω να γραψεις: sudo dmesg

και να ποσταρεις τα αποτελεσματα και απο τις δυο παραπανω εντολες για να δουμε τι παιζει;

1 Like

Δεν ξέρω αν έχει κάποια σημασία αλλά το συγκεκριμένο TP-LINK βγαίνει σε hardware version V1,V2,V3.

Πληροφορίες εδώ

1 Like

πρεπει να βαλει πρωτα το wpa_supplicant δεν το εχει

1 Like

Ο ενδιαφερόμενος που είναι; Και εφόσον μιλάμε για τοπική εγκατάσταση πακέτων θα πρέπει να κατεβάσει τα πακέτα που χρειάζεται και να τα εγκαταστήσει

pacman -U ~/διαδρομή/προς/το/πακέτο/packagename.tar.gz