Libreoffice έχει κολλήσει με την ανάκτηση

Καλημέρα

έχω το εξής πρόβλημα με το libreoffice στο Archlinux: κάθε φορά που το ξεκινώ, ανοίγοντας ένα υπάρχον αρχείο ή προσπαθώντας να δημιουργήσω νέο αρχείο, μου βγάζει το μήνυμα ότι λόγο σφάλματος κατέρρευσε και να κάνω ανάκτηση του αρχείου. Ακολουθώ τα βήματα αλλά δεν έχει αποτέλεσμα. Είτε κάνω απόρριψη είτε προχωρήσω για την ανάκτηση με ξαναγυρίζει στη αρχική σελίδα ανάκτησης εγγράφου και ξανά ξεκινάει η διαδικασία για την ανάκτηση εγγράφου.

Αν ξεκινήσω με την εντολή libreoffice --norestore μου βγάζει το μήνυμα ότι το soffice έκλεισε απρόσμενα και να ξαναξεκινήσω το πρόγραμμα.
Επίσης η libreoffice --norestore “αρχείο” πάλι με βγάζει στην ανάκτηση αρχείου.

Έχω δοκιμάσει τα εξής: διέγραψα από το .config τον φάκελο του libreoffice αλλά δεν είχε αποτέλεσμα
διάγραψα το .config τον φάκελο του libreoffice και έδωσα την εντολή pacman -Rns libreoffice αλλά και πάλι τα ίδια.
Έκανα επανεγκατάσταση του libreoffice 2-3 fφορές αλλά και πάλι τα ίδια.

Επίσης είδα ότι ίσως φταίνε “zombie” αλλα με την εντολή top είδα 0 zombie:

Tasks: 214 total, 1 running, 213 sleeping, 0 stopped, 0 zombie.

Ευχαριστώ για οποιαδήποτε βοήθεια.

Καλημέρα.
Δεν ξέρω αν βρήκες και δοκίμασες τα παρακάτω:

-Άνοιξε ένα πρόγραμμα (Calc ή Writer π.χ.)
-Στο βασικό μενού πάτα “Help” και εκεί μέσα “Restart in safe mode”
-Στο παράθυρο κάτω-κάτω άνοιξε “Advanced” και πάτα “Archive user profile”
-Μετά επέλεξε το υπομενού “Reset to factory settings”, και εκεί μέσα ενεργοποίησε το κουτάκι “Reset entire user profile”
-Θα ενεργοποιηθεί κάτω δεξιά το κουμπί “Apply changes and restart”. Πάτα και δες αν θα συνέλθει.

Δοκίμασα να ανοίγω το libreoffice και φτάνω εδώ image libreoffice

Οταν πατάω το βοήθεια με πετάει στο file:///usr/lib/libreoffice/help/el/text/shared/05/new_help.html
αλλ;a δεν μπορώ να βρω το restart in safe mode

Με libreoffice --safe-mode
μπήκα στο Επαναφορά Εργοστασιακών ρυθμίσεων
Επαναφορά της πλήρους κατατομής (προφίλ) χρήστη

αλλά δεν διορθώθηκε το πρόβλημα

καλό θα ήταν περισσότερες πληροφορίες για να υπάρχει μια πιθανότητα παραπάνω κάποιος να έχει μια σκέψη. Πχ ποια έκδοση libreoffice έχεις; και επίσης copy-paste το τερματικό τι βγάζει, όχι εξηγήσεις.

Τώρα μια προφανή ιδέα είναι αν έχεις το libreoffice-still να δοκιμάσεις το libreoffice-fresh ή το αντίστροφο.

Έχω libreoffice fresh 7.0.4-3

Το ίδιο πρόβλημα έχω και με το libreoffice -stll, του έκανα εγκατάσταση χθες και επειδή δεν είχε αποτέλεσμσ το έβγαλα και ξαναέβαλα το fresh

Τώρα που δοκίμασα να ανοίξω ένα αρχείο τερματικό βγάζει

qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 421, resource id: 0, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 152 (Unknown), sequence: 1215, resource id: 0, major code: 143 (Unknown), minor code: 2
qt.qpa.xcb: QXcbConnection: XCB error: 152 (Unknown), sequence: 1494, resource id: 0, major code: 143 (Unknown), minor code: 2
qt.qpa.xcb: QXcbConnection: XCB error: 152 (Unknown), sequence: 1879, resource id: 0, major code: 143 (Unknown), minor code: 2
qt.qpa.xcb: QXcbConnection: XCB error: 152 (Unknown), sequence: 2098, resource id: 0, major code: 143 (Unknown), minor code: 2
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 421, resource id: 0, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 421, resource id: 0, major code: 20 (GetProperty), minor code: 0

το συγκεκριμένο μάλλον είναι red herring :(

με γούγλισμα βρήκα κάτι που ταιριάζει στην περιγραφή σου.
https://bugs.archlinux.org/task/54594

και η πρόταση στα σχόλια είναι:

Όταν ανοίγω το libreoffice και μπαίνω εδώ ιmage libreoffice ](Screenshot-20210201-190316 — ImgBB)
πως θα ανοίξω τα tools? δεν μπορώ να ανοίξω κανένα αρχείο

κοίτα πάνω στο πάνελ έχει μενού «Αρχείο Εργαλεία Βοήθεια»

Περί safe mode, αν και προφανώς δεν έχει να κάνει, μήπως ξεκινάς πατώντας το κάτω κουμπί “βοήθεια” και σε πετάει στην ιστοσελίδα βοήθειας του libreoffice;
Το “restart in safe mode” είναι στο πάνω κουμπί.


Σε κάθε περίπτωση, αυτά που σου έγραψα προέρχονται από εδώ:
https://ask.libreoffice.org/en/question/228226/recently-installed-6403-x64-keeps-requiring-document-recovery-when-opening/
όπου πάνω-πάνω στην απάντηση εντοπίζει το πρόβλημα:
Registry
Ρίξε μια ματιά στα βήματα πάλι, μήπως παραλείπεις το “Advanced → Archive user profile”.
Αν χρειάζεται άλλου είδους “επέμβαση” στο αρχείο registrymodifications.xcu εγώ δεν μπορώ να σε βοηθήσω.
EDIT: Αν και η λύση είναι για πιο παλιά έκδοση της σουίτας, ως διαδικασία λειτουργεί και στην 7.0.4.2 που έχω.

Συγνώμη ξέχασα ότι είχα το help στο toolbar

Μπήκα στο Restart in Safe mode
μετά στο advanced
μετά πάτησα Archive user profile
και μου βγάζει το μήνυμα user profile has been exported as libreoffice_profile.zip
στον κατάλογο .config/libreoffice/4/user

θα προσπαθήσω να κάνω αυτό που που πρότεινε ο lucinos

Ακολούθησα τις οδηγίες
run libreoffice;
open “Tools->Options->Advanced”;
deselect “Use a Java runtime environment”.

όταν μπαίνω στο advaned εμφανίζονται οι ακόλουθες επιλογές

Α

όποια και να διαλέξω δεν λύνετε το πρόβλημα

Το πρόβλημα λύθηκε.
Επειδή είχαν κολλήσει και οι Ρυθμίσεις συστήματος και το xournal έψαξα στο internet και βρήκα
ότι για να ξεκολλήσουν οι Ρυθμίσεις συστήματος να χρησιμοποιηθεί η εντολή

systemsettings5 --style=Breeze

άλλαξα το global theme και όλα λειτουργούν κανονικά

2 Likes

Αυτό το νήμα έκλεισε αυτόματα 2 ημέρες μετά την τελευταία απάντηση. Δεν επιτρέπονται πλέον νέες απαντήσεις.