Kubuntu 16.04 Δεν αλλάζει διάταξη μέσω ibus με συνδιασμό Alt+Shift

Στο laptop έχω Kubuntu 16.04LTS και επειδή θέλω να γράφω Ιαπωνικά ενεργοποίησα το ibus και αξιοποιώ αυτό για να μπορώ να γράφω μέσω Anthy Ιαπωνικά.

Όμως παρόλο που μέσω μενού μπορώ να αλλάξω την γλώσσα δεν μπορώ να την αλλάξω με Alt+Shift.

Έχετε κάποια ιδέα γιατί;

Περισσότερες πληροφορίες: https://askubuntu.com/q/1176913/540746 (Στα screenshots έχω τι έχω κάνει.) Δεν χρησιμοποιώ την DEFAULT ιαπωνικά διάταξη αλλά το Anthy λόγο ότι πληκτρολογόντας Romanji μπορώ να τα μετατρέπω σε Ιαπωνικούς χαρακτήρες ανάλωγα με το πως προφέρετε η λέξη.

1 Like

Ομορφες καλησπερες.Αν καταλαβα καλα με τον τροπο αυτο θες να κανεις
αυτο που λεμε transiteration επειδη η default διαταξη των ιαπωνικων
στο πληκτρολογιο δεν ειναι φωνητικη καλα τα λεω?
Mia ακομα ερωτηση το ibus ειναι προεγκατεστημενο στο Kubuntu?
Eγω καποτε ειχα προβλημα να γραψω ελληνικα και χρησιμοποιωντας
το ibus τα καταφερα.Δες κι εδω τι εκανα καποτε που ποσταρισα
στην ομαδα του Λινουξ Μιντ στο φεησμπουκ ισως να σε βοηθησει.
Mporoysa μαλιστα να αλλαζω γλωσσες με alt+shift.

Επισης θα σου προτεινα να ριξεις μια ματια και σε αυτο το topic.
Περιλαμβανει οδηγιες και για τα Romanji.

Δεν βοηθάνε τα links ήδη έχω βάλει και ενεργοποιήσει το ibus. Τo πρόβλημα είναι η μη “ενεργοποίηση” των χαρακτήρων.

1 Like

Δοκίμασε να βάλεις διαφορετικό και συγκεκριμένο συνδυασμό για αυτή την γλώσσα,
πχ Meta+Spacebar

Ean καταλαβα καλα καλε φιλε @pc_magas
θελεις με τα Romanji να κανεις transliteration
να γραφεις δηλαδη την λεξη με τον τροπο
που προφερεται και να εμφανιζεται η λεξη
στα ιαπωνικα καλα τα λεω ?
Πες μας περιπου τι εκανες κατα την διαρκεια της εγκαταστασης του
ibus?
Κατα τη διαρκεια της εγκαταστασης επελεξες τα adittional features?

Επειδή χρησιμοποιώ κι εγώ το ibus για ιαπωνικά, νομίζω ότι μόνο στο GNOME είναι δυνατό το να χρησιμοποιήσεις το Alt+Shift χωρίς επιπλέον ρυθμίσεις, εάν θυμάμαι σωστά.

Σε άλλα γραφικά περιβάλλοντα (KDE, XFCE κλπ) μπορείς ρυθμίσεις το shortcut για την αλλαγή input μέσω των ρυθμίσεων του ibus. Δυστυχώς δε νομίζω ότι δουλεύει μόνο με Alt+Shift, αλλά μπορείς να χρησιμοποιήσεις κάποιον άλλο συνδυασμό (προσωπικά χρησιμοποιώ το Ctrl+Alt+i, αν και δε λειτουργεί όταν το keyboard είναι στα ελληνικά) ή μπορείς να χρησιμοποιήσεις το tray του ibus για να αλλάξεις το input εκεί.

2 Likes

Η εγκατάσταση του ibus έγινε μέσω της εντολής:

sudo apt install ibus ibus-qt ibus-anthy im-config
sudo apt install ibus-qt*
sudo apt install anthy #Anthy είναι ια Ιαπωνικά
im-switch -s ibus #Use ibus

Και για τον χρήστη μου λέω να τρέχει το ibus αυτόματα όπως βλέπεις στο screenshot:

Μετά απενεργοποίησα τελείως τις ρυθμίσεις του KDE για την εναλλαγή γλώσσας για να αφήσω το ibus να αναλάβει την εναλλαγή:

Και ρυθμίζω το ibus να αξιοποιεί το Αλτ+Σιφτ μέσω του ibus-config αλλά δεν μου παίζει όταν πάω να κάνω την εναλλαγή της γλώσσας. Αλλά άλλοι συνδιασμοί όπως Controll+Space παίζουν.

Ακόμη οι εν λόγο μεταβλητές περιβάλλοντος έχουν οριστεί:

pcmagas@pcmagas-Lenovo-G70-70:~$ echo $GTK_IM_MODULE
ibus
pcmagas@pcmagas-Lenovo-G70-70:~$ echo $XMODIFIERS
@im=ibus
pcmagas@pcmagas-Lenovo-G70-70:~$ echo $QT_IM_MODULE
ibus

Άρα στανταράκι το ibus είναι ρυθμισμένο σωστά. Μήπως ξερετε μέσω script πως μπορώ να εναλλάσω την γλώσσα;

Δεν νομίζω ότι ισχύει αυτό. Χθες εγκατέστησα arch + kde και ρύθμισα το alt-shift για αλλαγή γλώσσας μόνο μέσα από το kde. Πρόσφατα έστησα manjaro + cinnamon: το ίδιο. Πριν μια βδομάδα raspbian: ομοίως.

Απ’ ο,τι φαίνεται, μόνο στο GNOME μπορείς να το έχεις με Alt + Shift, επειδή εκεί αναγνωρίζεται μέσω των ρυθμίσεων. Δε νομίζω ότι δουλεύει με παρόμοιο τρόπο σε άλλα γραφικά περιβάλλοντα.

Έχω απορία εάν υπάρχει εντολή μέσω της οποίας μπορώ να επικοινωνεί στο ibus και μετά να του λέει άλλαξε γλώσσα. Εαν ναι μετά θα είναι πολύ απλό απλά να ρυθμίσω με τις ρυθμίσεις για shortcut του KDE να αλλάζει.

Γίνεται να αλλάζει και με το alt+shift στο KDE, απλά έλεγξε 2 πράγματα αφού όλα τα άλλα φαίνεται να τα έχεις κάνει.

  1. Άνοιξε με δεξί κλικ το ibus preferences και στο πεδίο next input method γράψε το εξής :
    <Alt>Shift_L
  2. Απενεργοποίησε εντελώς την συντόμευση alt+shift στα
    System Settings->Input Devices->Advanced->Switching to another layout->alt+shift (ξετίκαρέ το)

Το δοκίμασα αλλά δεν βλέπω προκοπή:

%CE%A0%CF%81%CE%BF%CF%84%CE%B9%CE%BC%CE%AE%CF%83%CE%B5%CE%B9%CF%82%20IBus_010

Και η επίσημή κοινότητα δεν δίνει λύση, λόγο ότι το Kubuntu δεν ακολουθά το 5ετές κύκλο του κανονικού, ενα αντιθέση η LTS έχει 3 χρόνια υποστήριξη.

Μετά τις αλλαγές, κάνεις αποσύνδεση και επασύνδεση για να κάνει restart o daemon?
Μπορείς και με την εντολή :
ibus restart

Ναι έκανα, βασικά είχα κλείσει (shutdown) το laptop και μετά το ξανα άνοιξα άρα ο ibus θα πηρε φρέσκιες ρυθμίσεις η οποίες ήταν για εναλλαγή γλώσσας ‘<Alt>Shift_L`.

Μα όλη την διαδικασία την κάνω επειδή το ΙΔΙΟ το KDE δεν σου δίνει την επιλογή να επιλέγεις το Anthy σαν μέθοδοι εισαγωγής Ιαπωνικών μέσα από τις ρυθμίσεις που σου δίνει, εν αντιθέση με το GNOME/default ubuntu.

Να πω την αλήθεια προσωπικά ακούω ibus και τρέμω.

2 Likes

Προτιμάς την χρήση του fcitx (πρόσφατα έμαθα ότι δυσκολεύομαι να το ορθογραφήσω);

Δοκίμασε το εξής, εγκατέστησε το : libglib2.0-bin
sudo apt install libglib2.0-bin
και τρέξε την παρακάτω εντολή :
gsettings set org.freedesktop.ibus.general.hotkey triggers "['<Alt>Shift_L']"
και έλεγξε αν έχεις αποτελέσματα.

Όχι δεν βλέπω κάποια διαφορά. Μάλλον να δω να βάλω κάτι ποιο φρέσκο από distro.

Περίεργο, σε virtual-box που έστησα με kubuntu 16.04, με τα παρακάτω πακέτα :
anthy anthy-common dconf-cli gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-gtk-3.0 gir1.2-ibus-1.0 gir1.2-pango-1.0 ibus ibus-anthy libanthy0
το κατάφερα και δούλεψε, με 3 γλώσσες (αγγλικά, ελληνικά και ιαπωνικά).