H οθόνη "μίκρυνε"

Καλησπέρα, παιδιά!
Μετά από πολύ καιρό που άνοιξα το desktop, βλέπω πως δεν χρησιμοποιείται όλη η επιφάνεια της οθόνης και στα settings απλά αναφέρεται ως unknown display. H κάρτα γραφικών είναι nvidia και από όσο μπορούσα να ελέγξω οι drivers είναι up to date.

Κάποια βοήθεια;;;

1 Like

Για αρχή κάνουμε τα βασικά , βαλε - βγάλε καλώδια, on - off την οθόνη κοτσαρισμένη η όχι στον υπολογιστή σε διάφορους συνδιασμούς, μα πάνω απ’ όλα περισσότερες πληροφορίες για το μηχάνημά σου π.χ. ένα inxi -SCGAN θα βοηθούσε νομίζω…

Α και ένα πλήρες update από τερματικό, αυτό ίσως να το κάνεις πρώτο.

Καμιά φορά η λύση στο πρόβλημα μπορεί να είναι τόσο απλή που να τραβάς τα μαλλιά σου

Update έγινε πλήρες, πριν στείλω τη δημοσίευση.
Καλώδιο μπήκε-βγήκε, έκανα on-off, ξεμάτιασμα…δεν πέτυχε τίποτα.

rockingchairu@rockingchairu-GA-MA770T-UD3P:~/Downloads$ inxi -SCGAN
System:    Host: rockingchairu-GA-MA770T-UD3P Kernel: 4.15.0-88-generic i686
           bits: 32
           Desktop: Gnome 3.28.4 Distro: Ubuntu 18.04.4 LTS
CPU:       Dual core AMD Athlon II X2 250 (-MCP-) cache: 2048 KB
           clock speeds: max: 3000 MHz 1: 1800 MHz 2: 1800 MHz
Graphics:  Card: NVIDIA GF119 [GeForce GT 520]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: vesa,nouveau (unloaded: modesetting,fbdev)
           Resolution: 1920x1080@0.00hz
           OpenGL: renderer: llvmpipe (LLVM 9.0, 128 bits)
           version: 3.3 Mesa 19.2.8
Audio:     Card-1 Creative Labs EMU20k1 [Sound Blaster X-Fi Series]
           driver: snd_ctxfi
           Card-2 NVIDIA GF119 HDMI Audio Controller driver: snd_hda_intel
           Card-3 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-88-generic
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169

νομίζω δεν έχεις τούς σωστούς drivers. Αν και με μπερδεύει γιατί αναφέρει neouvau πιο πάνω (αναφέρει όμως και vesa)

Πως θα μάθω ποιοι είναι οι σωστοί; Είμαι και σχετικά άσχετος.

Κοίτα μήπως έκανες αναβάθμηση πυρήνα, αν έκανες στο ΤΕΛΕΥΤΑΊΟ update, δοκίμασε έναν παλαιότερο μήπως είναι από εκεί το θέμα γιατί βλέπω ότι 'εχεις και τα δύο vesa,nouvea και αυτό μου φαίνεται κάπως…

από την άλλη μπορεί να λέω και μπαρούφες :innocent:

nouveau: οι ανοικτοί οδηγοί (από την κοινότητα τού ελεύθερου λογισμικού)
nvidia: οι κλειστοί οδηγοί (από την ίδια την nvidia)
vesa: δεν κάνουν καθόλου επιτάχυνση (τα πάντα γίνονται από cpu) υπάρχουν για να έχεις τουλάχιστον εικόνα αν δεν δουλέψουν οι κανονικοί οδηγοί.
modesetting,fbdev δεν σε ενδιαφέρουν, επίσης λάθος οδηγοί. (σωστά όμως είναι unloaded)

Εσύ θες να δουλεύουν σωστά οι nouveau ή οι nvidia.

νομίζω θα έπρεπε η vesa να είναι unloaded. Επίσης το llvmpipe νομίζω σημαίνει ότι γίνεται από την cpu άρα μάλλον δεν παίζουν σωστά.

δώσε και ένα

glxinfo -B

Είναι λίγο παράξενο ότι έχεις 32bit και όχι 64bit. Να ξέρεις ο επεξεργαστής σου είναι 64bit. Πιθανόν δεν έχει σχέση με το πρόβλημα αλλά ειδικά το ubuntu έχει σταματήσει εντελώς την υποστήριξη στα 32bit.

Όταν πρωτοέβαλα Ubuntu κατα λάθος έβαλα 32bit, βολευτηκα και δεν εχω χρόνο τώρα για φρέσκο install.

rockingchairu@rockingchairu-GA-MA770T-UD3P:~/Downloads$ glxinfo -B
name of display: :1
display: :1  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: VMware, Inc. (0xffffffff)
    Device: llvmpipe (LLVM 9.0, 128 bits) (0xffffffff)
    Version: 19.2.8
    Accelerated: no
    Video memory: 5997MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 9.0, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.2.8
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.1 Mesa 19.2.8
OpenGL shading language version string: 1.40
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.0 Mesa 19.2.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

Θα κάνω clean install Ubuntu 64 για να δούμε αν θα επανέρθουν οι διαστάσεις της οθόνης.

Λογικά θα δεις ήδη από το Live. Αυτό είναι σημαντικό μήπως ξεκαθαρίσει αν τα έχει φτύσει η κάρτα γραφικών.

Προσωπικά έχω την παράξενη εμπειρία οι nouveau να κάθονται σωστά μόνο σε διανομές βασισμένες στο debian (όχι στο ubuntu), αλλά αυτό είναι απλά δική μου παράξενη εμπειρία και δεν έχω εξήγηση.

Δε νομίζω ότι έχει πρόβλημα η κάρτα γραφικών. Μάλλον το πρόβλημα προήλθε από την ενημέρωση του πυρήνα και την ελλειπή ενημέρωση/εγκατάσταση του κλειστού οδηγού της NVIDIA. Έχω AMD κάρτα τα τελευταία(αρκετά) χρόνια, αλλά θυμάμαι αρκετές φορές να έχω πρόβλημα με τον κλειστό οδηγό της NVIDIA μετά από ενημέρωση πυρήνα(το οποίο συνήθως λυνόταν με επανεγκατάστασή του).
Στο log που παρέθεσε αναφέρεται το:
drivers: vesa,nouveau (unloaded: modesetting,fbdev)
Resolution: 1920x1080@0.00hz
Δεν έχω χρησιμοποιήσει το inxi αλλά βλέπω ότι έχει τον vesa οδηγό πρώτο, οπότε νομίζω ότι αυτός χρησιμοποιείται, και όχι ο nouveau. Ο VESA δεν υποστηρίζει την ανάλυση 1920x1080, και μάλλον αυτός ήταν ο λόγος που η επιφάνεια εργασίας εμφανίστηκε σε ένα μικρό μέρος της οθόνης.

Εγκατέστησα λοιπόν το Ubuntu 18.04 lts για 64 bits αυτη τη φορά και η οθόνη επανήλθε. Επίσης, καιρός ήταν να γίνει clean install γιατί αρχικά είχα dual boot με win 7 , τα οποια αφαιρεσα απο terminal, οποτε σιγουρα κατι ειχε μεινει σαν φάντασμα. Λύθηκε λοιπόν, το πρόβλημα! Σας ευχαριστώ!

1 Like