Η διανομή σας βλέπει τα ασύρματα δίκτυα, δίνετε σωστό pass, αλλά δεν συνδέεται; Ιδού η λύση!

Πρόσφατα κατάφερα να λύσω ένα πρόβλημα που με ταλαιπωρούσε καιρό σε μικρό βαθμό και κορυφώθηκε μετά την αγορά του νέου μου laptop. Συμπτώματα;

  1. Στο παλιό μου laptop (δεκαετίας i5) φαινόντουσαν κανονικά τα δίκτυα αλλά μερικές φορές (1/10) δεν συνδεόταν με το wifi, ενώ έδινα σωστό pass. Μια επανεκκίνηση έλυνε το θέμα, οπότε μια που η χρήση του laptop ήταν περιορισμένη στο σπίτι, δεν είχα ασχοληθεί ιδιαίτερα θεωρώντας ότι επρόκειτο για ιδιοτροπία της κάρτας wifi του laptop σε συνδυασμό με το Linux.

  2. Πρόσφατα η (πρώην) σύζυγος προσπαθούσε να συνδέσει ένα chromebook το οποίο με τίποτα δεν ήθελε να συνδεθεί στα 2.4 GHz ενός tplink powerline, αλλά συνδεόταν απροβλημάτιστα στα 5 GHz. Τέλος πάντων, έφυγε η σύζυγος, δεν ασχολήθηκα.

  3. Πριν λίγες εβδομάδες αγόρασα νέο laptop. Το laptop συνδεόταν (Linux Mint 21) κανονικά στο wifi του router, αλλά δεν ήθελε με την καμία να συνδεθεί στα 2.4 GHz του powerline στον πάνω όροφο. Στα 5 GHz συνδεόταν κανονικά. Σε αυτό το σημείο αντιλήφθηκα και το pattern και άρχισα να το ψάχνω περαιτέρω, καθώς τα 5 GHz είναι μεν πιο γρήγορα αλλά έχουμε θεματάκι με τις μεσοτοιχίες οπότε ήθελα να συνδέεται στα 2.4 GHz.

Μετά από αρκετό ψάξιμο, διαπίστωσα ότι α) δεν είμαι ο μόνος που αντιμετωπίζει τέτοια προβλήματα β) ο “κοπρίτης” είναι το wpa_supplicant, ένα service που είναι υπεύθυνο για τη διασύνδεση μέσω WPA2, WPA3 κτλ. Ευτυχώς υπάρχει ένα πολύ πιο efficient και πλέον σταθερό service που αναπτύσσεται από την Intel, το iwd, που κάνει την ίδια δουλειά και καλύτερα. Λογικά θα υιοθετηθεί σαν βασικό στο μέλλον από τις περισσότερες διανομές.

Αν λοιπόν έχετε θεματάκι διασύνδεσης, μπορείτε να ακολουθήσετε τις οδηγίες (σε Linux Mint) και να λύσετε μια και καλή το πρόβλημα:

1) Εγκαθιστούμε το iwd

sudo apt update
sudo apt install iwd

2) Δημιουργούμε το παρακάτω αρχείο εντός του φακέλου ρυθμίσεων του NetworkManager

sudo xed /etc/NetworkManager/conf.d/wifi_backend.conf

3) Copy/paste εντός του αρχείου τα παρακάτω και αποθηκεύουμε:

[device]
wifi.backend=iwd

4) Σταματάμε και απενεργοποιούμε το wpa_supplicant service (η αλλαγή γίνεται μόνιμη μετά το reboot)

systemctl stop wpa_supplicant.service
systemctl disable wpa_supplicant.service

5) Ενεργοποιούμε και εκκινούμε το iwd service (η αλλαγή γίνεται μόνιμη μετά το reboot)

sudo systemctl enable iwd.service
sudo systemctl start iwd.service

6) Επανεκκινούμε το PC και ελέγχουμε αν λύθηκαν τα προβλήματα διασύνδεσης. Σε εμένα δούλεψε ρολόι!

6 «Μου αρέσει»

To ‘xed’ τι είναι; Editor ;
@Maras ευχαριστώ για τν απάντηση.
@linuxovios ευχαριστούμε για το tip. Επιβεβαιώνω ότι λειτουργεί. Συγκεκριμένα σε τάμπλετ με Fedora 37 (πρόσφατη εγκατάσταση) δεν συνδεόταν σε hotspot κινητού τηλεφώνου και στην κοινόχρηστη χρήση wifi υπήρχε προβληματική σύνδεση. Με το iwd όπως προτείνεις λύθηκαν άμεσα τα προβλήματα. Το μόνο που δεν γνωρίζω είναι αν υπάρχει πρόβλημα με την εγκατάσταση άλλων προγραμμάτων σε περίπτωση που εξαρτώνται από το `wpa_supplicant.

Ναι έρχεται από τον Pluma.
Xed

Εννοείται ότι αντί για τον xed μπορείτε να χρησιμοποιήσετε όποιον editor επιθυμείτε π.χ. gedit κ.α.

1 «Μου αρέσει»

Όπως είδες @linuxovios παραπάνω το κολπάκι δούλεψε τέλεια ευχαριστούμε πολύ!!!

1 «Μου αρέσει»

Απ’ όσο έχω καταλάβει, τόσο το wpa_supplicant όσο και το iwd είναι services που υλοποιούν τη σύνδεση με κάποιο wifi με κρυπτογράφηση WPA2/3 κτλ. Δεν νομίζω ότι μπορούν να επηρεάσουν κάποιο λογισμικό καθώς λειτουργούν σε άλλο επίπεδο (layer) σε σχέση με τον κώδικα μιας εφαρμογής.

1 «Μου αρέσει»

ουφ ευτυχώς…πολύ καθησυχαστικό γεγονός. Το iwd δουλεύει …