frostwire σε manjaro δεν τρεχει

το frostwire σε manjaro δεν τρεχει

HOSTNAME IS kostas-w251esqw270esq
Starting FrostWire...
Java exec found in PATH. Verifying...
Suitable java version found [java = 1.8.0_265]
Configuring environment...
Loading FrostWire:
Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/limegroup/gnutella/gui/Main has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:756)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:468)
	at java.net.URLClassLoader.access$100(URLClassLoader.java:74)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:369)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:363)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:362)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:418)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:351)
	at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495)


******************************************************************
Something went wrong with FrostWire.
Maybe you're using the wrong version of Java?
(FrostWire is tested against and works best with with Sun's JRE, Java 1.7+)
The version of Java in your PATH is:
openjdk version "1.8.0_265"
OpenJDK Runtime Environment (build 1.8.0_265-b01)
OpenJDK 64-Bit Server VM (build 25.265-b01, mixed mode)

με ποιον τρόπο το εγκατέστησες; Υπάρχει στο AUR. Δεν το έχω δοκιμάσει αλλά αυτός είναι ο πιο εύκολος τρόπος.

γενικά για την java δες https://wiki.archlinux.org/index.php/Java

Επίσης γενικά για Torrent απλά χρησιμοποίησε κάποια εφαρμογή που έχει κανονική υποστήριξη, πχ transmission ή ktrorrent

1 Like

Εδω ειναι το προιβλημα σου. Θελει το JRE της Oracle και οχι το OpenJDK

1 Like

ευχαριστω για την βοηθεια λυθηκε το προβλημα

1 Like

Αυτό το νήμα έκλεισε αυτόματα 2 ημέρες μετά την τελευταία απάντηση. Δεν επιτρέπονται πλέον νέες απαντήσεις.