Errno 5, σε VirtualBox

¨Εχω ένα Laptop 14" με Intel 4300u, 8GB ram, 256 SSD + 500 HDD, Intel graphics και dual boot win10 και Mint 19.3. Τα λειτουργικά είναι εγκατεστημένα στον SSD

Θέλω να εγκαταστήσω μια διανομή Linux σε Oracle Virtual Box 6.1 (στον HDD), για να κάνω κάποιες συγκεκριμένες εργασίες. Αυτό που συμβαίνει είναι ότι όταν προσπαθώ να κάνω εγκατάσταση μια διανομή παίρνω το μήνυμα ennro 5 input/output error και δεν προχωράει η εγκατάσταση. Έχω δοκιμάσει τα εξής

  • Διανομές : Mint (Xfce και mate), Ubuntu Mate και Xubuntu καθώς και Linux Lite.
  • Έχω ελέγξει τα .iso με MD5, SHΑ256 κτλπ
  • Έχω ελέγξει τους δίσκους και έχω αλλάξει τον 500 με SSD
  • Έχω ενεργοποιήσει/απενεργοποιήσει το PAE/NX
  • Έχω δοκιμάσει και σε win και σε Mint
  • Έχω ενεργοποιήσει το Virtualization στο BIOS

Ουσιαστικά δεν με ενδιαφέρει ποια διανομή θα εγκαταστήσω (θα προτιμούσα βέβαια κάποια ubuntuειδές), καθώς ούτε σε ποιο λειτουργικό θα τρέχει το VM, αλλά οπωσδήποτε θα πρέπει να είναι το VM της Oracle.

Καμιά ιδέα;

Μπες στο BIOS και δες αν είναι ενεργοποιημένη η εικονοποιηση του επεξεργαστή.

Ναι ξέχασα να το αναφέρω, είναι ενεργοποιημένο

Κάνε μια εξέταση του δίσκου σου. Μου θυμίζει κάτι από bad sectors

Το έκανα και στους 2. Έχω 100% υγεία και κανεναν bad sector. Για σιγουριά έβγαλα τον HDD και τον αντεκατεστησα με έναν δεύτερο SSD που είχα.

Κάτι τέτοιο; Για τσέκαρε το md5 του iso ή κατέβασε το με torrent

το έχω κάνει σε όλα τα .iso.

λιγο που το εψαξα, ειδα και καναδυο περιπτωσεις με προβλημα στη μνημη. Ισως να εκανες και ενα memtest ;

Το είχα διαβάσει και γω και είχα τρέξει το test των windows, το οποίο πέρασε χωρίς πρόβλημα. Τώρα που το ανέφερες αποφάσισα να κατεβάσω και να τρέξω το memtest και συμβαίνει το εξής… Όταν τεστάρω το laptop από live usb δεν δείχνει κάποιο πρόβλημα στις μνήμες (και γενικά δεν έχω παρατηρήσει κάποιο πρόβλημα στο laptop). Όμως αν τρέξω το memtest μέσα από το VM , μου κοκκινίζει τις μνήμες…

τοτε ισως να υπαρχει προβλημα με τη μνημη, αν πιστεψουμε αυτο που λεει εδω → https://communities.vmware.com/message/1068942#1068942
μονο που ειναι αρκετα παλιο το αρθρο…

@likos αφού ελέχθηκαν όλες οι περιπτώσεις όσων απάντησαν θα σου πρότεινα να δοκιμάσεις και ένα downgrade σε virtualbox 5.2 με την πρυπόθεση ότι δεν χάνεις κάποιο feature που χρειάζεσαι.

Το δοκίμασα και αυτό σε windows. Εδώ το περίεργο είναι ότι μου δίνει δυνατότητα μόνο για εγκατάσταση x32 guests (δοκίμασα τα hyper-v και διάφορα τέτοια, αλλά πάλι τίποτα). Το μόνο που έμεινε είναι να “παίξω” με τις μνήμες να δω αν όντως φταίνε αυτές και αναγκαστικά θα δουλέψω στον σταθερό μου.

ΥΓ. Επίσης δοκίμασα να δώσω διάφορες τιμές στα guest μηχανήματα από 1024 μέχρι 4096, χωρίς αποτέλεσμα.

Στο Mint και με Virtual Box 5.2.34 (δηλαδή αυτό που υπάρχει στο software center), δουλεύουν όλα ρολόι.
Και εγκαταστάσεις κάνει και το memtest περνάει. Οπότε φαντάζομαι ότι το πρόβλημα είναι στην έκδοση 6 του virtual box.

2 Likes