End kernel panic - not syncing: Attempted to kill init - Υπάρχει λύση;

Καλησπέρα και καλό μήνα!

Το μηχάνημα είναι παλιό, δεκαετίας και έχω εγκαταστήσει Linux Mint 19,2 αλλά ποτέ δεν ολοκληρώθηκε η εγκατάσταση, καθώς κολλούσε πριν γίνει κατά το κλείσιμο της συνεδρίας, ενώ και αυτή η εγκατάσταση άνοιγε μια φορά και μετά εμφάνιζε κάτι. Το μηχάνημα γενικώς έχει πρόβλημα σε όλες τις εκδοχές ubuntu και mint έχω δοκιμάσει να εγκαταστήσω.

Μήπως είναι θέμα σκληρού δίσκου κι αν ναι υπάρχει λύση για να συνεχίσω να χρησιμοποιώ το λάπτοπ;

Δεν είναι πολύ πιθανό αυτό που θα πω, αλλά το αναφέρω γιατί μού είχε συμβεί σε πιο παλιό από το δικό σου δικό μου παλιό λαπτοπ αν και ήταν 64bit είχα παρόμοιο πρόβλημα με 64bit εκδόσεις. Οι 32bit ήταν μια χαρά. Τώρα αν θες να το δοκιμάσεις αυτό, καλώς ή κακώς το ubuntu έχει σταματήσει την υποστήριξη 32bit οπότε αν θες να το δοκιμάσεις αυτό μπορείς να δεις πχ με Sparky που έχει 32bit έκδοση.

Αν όντως είναι αυτό, τότε η υπόθεσή μου είναι ότι ο πυρήνας έχει γίνει compile με συνθήκες για πιο καινούργιους επεξεργαστές, οπότε ή κάθεσαι με την 32bit ή αν είσαι αρκετά μουρλός μπορείς να κάνεις ο ίδιος compile τον πυρήνα :stuck_out_tongue:

1 Like

Για δώσε περισσότερες πληροφορίες για τον υπολογιστή

μπορει να ειναι η λυση στο λαπτοπ toshiba sattelite που κολλαει στην επανεκινηση τερματισμο αναστολη. ενω ειναι 64bit και βαζω 64 bit διανομες. θα δοκιμασω μια 32bit.

αν εισαι τυχερος πρεπει να ειναι Core 2 Duο T6670, αρα 64bit.
Δωσε στο τερματικο
inxi -F
να δουμε τι ψαρια πιανει.

Είναι 64bit αλλιώς δεν θα έφτανε καν ως εκεί, όπως 64bit ήταν και ο δικός μου στον οποίο αναφέρθηκα.

Το δικό σου θέμα θυμίζει πολύ λιγότερο αυτό που λέω. Το τραβάς πολύ να το συσχετίζεις. Έχω γράψει κάτι εκεί που θα ήθελα να δοκιμάσεις και με την ευκαιρία να πω ότι σκέφτομαι ότι ίσως σχετίζεται με τον DM.

μπορει να μην ισχυει πραγματι. αλλα σε ενα λαπτοπ 10 ετων και βάλε δεν χανω τιποτα να δοκιμασω. δεν το εχω στα χερια μου αλλιως θα ειχα ηδη δοκιμασει ολες τις λυσεις που προτεινατε.

Κατ’ αρχάς, τρέξε κάποιο bootable memtest και διαγνωστικό δίσκου. Ανάφερε τα αποτελέσματα.

Καλημέρα και ευχαριστώ για τις απαντήσεις.

Στέλνω το ραπόρτο από τον inix-F:

System:
  Host: mint Kernel: 4.15.0-20-generic x86_64 bits: 64 
  Desktop: Cinnamon 4.0.8 Distro: Linux Mint 19.1 Tessa 
Machine:
  Type: Laptop System: FUJITSU SIEMENS product: ESPRIMO Mobile V6555 
  v: V1.21 serial: <root required> 
  Mobo: FUJITSU SIEMENS model: Z17M3.0 v: 20 serial: <root required> 
  BIOS: Phoenix v: 1.21 date: 11/27/2009 
Battery:
  ID-1: BAT0 charge: 8.6 Wh condition: 11.5/47.5 Wh (24%) 
CPU:
  Topology: Dual Core model: Pentium T4400 bits: 64 type: MCP 
  L2 cache: 1024 KiB 
  Speed: 1200 MHz min/max: 1200/2200 MHz Core speeds (MHz): 1: 1200 2: 1200 
Graphics:
  Device-1: NVIDIA MCP79 [GeForce 8200M G] driver: N/A 
  Display: x11 server: X.Org 1.19.6 driver: vesa resolution: 1280x768~N/A 
  OpenGL: renderer: llvmpipe (LLVM 6.0 128 bits) v: 3.3 Mesa 18.0.5 
Audio:
  Device-1: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k4.15.0-20-generic 
Network:
  Device-1: NVIDIA MCP79 Ethernet driver: forcedeth 
  IF: enp0s10 state: up speed: 100 Mbps duplex: full mac: 00:1e:33:e0:de:95 
Drives:
  Local Storage: total: 473.22 GiB used: 124.5 MiB (0.0%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS545050B9A300 size: 465.76 GiB 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Fit size: 7.45 GiB 
Partition:
  ID-1: / size: 1.22 GiB used: 124.5 MiB (10.0%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 72.8 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 161 Uptime: 13m Memory: 2.44 GiB used: 1014.2 MiB (40.6%) 
  Shell: bash inxi: 3.0.27

Κάτι δεν παει καλά με το hard drive νομίζω…

Αν και αυτό είναι σίγουρα άσχετο με το πρόβλημα, απλά σημειώνω ότι δεν έχει κάτσει σωστά ο driver για την κάρτα γραφικών. Και αυτό μού θυμίζει έναν άλλο παλιό υπολογιστή μου που για κάποιον λόγο σε manjaro δεν κάθονταν σωστά οι ανοικτοί οδηγοί (αλλά παίζαν οι κλειστοί 304) ενώ σε debian παίζαν μια χαρά οι ανοικτοί (οπότε δεν έκανα τον κόπο να ασχοληθώ με τούς κλειστούς), στο ubuntu/mint που είχα δοκιμάσει δεν είχα κοιτάξει μάλλον όμως δεν είχαν καθήσει ούτε εκεί καλά οι ανοικτοί γιατί έπαιζε χάλια.

Και το δικο μου παίζει καλά μόνο με τους κλειστος οδηγούς. Με τους ανοικτούς παρουσίαζε πρόβλημα.
Πως μπορώ να τσεκάρω τον σκληρό; Με το DIsks, το GParted?

Με το Disks

2 Likes