Δεν μπαίνει στο desktop.

Δεν μπαίνει στο desktop.
Γίνεται αυτόματο login user και έχει xfce4.
Βγάζει μήνυμα στα ελληνικά και δεν έχω την δυνατότητα να είμαι μπροστά στον υπολογιστή, ενώ ο χρήστης είναι τελείως άσχετος.
Είδα πως μπαίνει σε terminal mode.

Πες του να δοκιμάσει με CtrlAltF2 να μπει σε tty2 και εκεί να κάνει login με τα στοιχεία του (username και password) και να δώσει στο τερματικό

startxfce4

Σε τυχόν λάθος, να στείλει το output

ΥΓ. Αν δεν είχα χτυπήσει σουβλάκια θα μου είχες ανοίξει την όρεξη :stuck_out_tongue:

1 Like

Να κι άλλος με το ίδιο πρόβλημα. :grinning:
Μόλις πόσταρα κι εγώ θέμα σχετικό μ’ αυτό.

1 Like

Πως να στείλει το output;

ΥΓ: πλέον καλή χώνεψη ;)

Επέλεξε το από το τερματικό, κάνε δεξί κλικ και αντιγραφή. Έλα εδώ κάνε δεξι κλικ και επικόλληση. Επέλεξε τα ξανά εδώ και πάτησε το

image

Επειδή μοιάζει με το δικό μου πρόβλημα τσέκαρε μήπως έχετε εγκατεστημένο το xlogin απ’ το aur.

Το pc δεν είναι στα χέρια μου, δεν έχω φυσική παρουσία και ο ιδιοκτήτης- χρήστης ΔΕΝ έχει επαφή με το φόρουμ ούτε μπορεί να έχει.
Φωτογραφία μόνο από κινητό.

Αυτό δε βοηθάει ιδιαίτερα. Το σφάλμα αυτό βγαίνει γιατί προσπαθεί να τρέξει 2ο xserver στο ίδιο DISPLAY(“Server is already active for display 0”). Μπορεί να δοκιμάσει αυτό:

startxfce4 -- :1 vt2

(αν είναι στη δεύτερη κονσόλα “tty2”).
*είναι 2 παύλες όχι μία)

Φάνηκε να τρέχει κάτι και έμεινε σε μαύρη οθόνη με τον κέρσορα πάνω αριστερή γωνία να αναβωσβήνει (όλα αυτά στο tty2)
Μετά από ώρα τον πήγα στο tty1 και ήταν όπως στην εικόνα παρακάτω…

δοκίμασε να κάνει αυτό που λέει το παραπάνω μήνυμα; δηλαδή:

sudo rm /tmp/.X0-lock
3 Likes

Σωστή σκέψη και το έκανα.
Έτρεξα το
startxfce4 -- :1 vt2
και έβγαλε τα μυνήματα των φωτογραφιών

Έκανα επανεκκίνηση το αρχικό πρόβλημα παρέμεινε.
Ξανά έκανα την όλη διαδικασία αλλά ΔΕΝ έκανα επανεκκίνηση, απλά έτρεξα το
startx
και μπήκε στο desktop

Έκανα επανεκκίνηση και παρέμεινε το πρόβλημα!!!

Η βασική μου σκέψη είναι να δοκιμαστούν άλλοι πυρήνες.

Την πληροφορία ποιος πυρήνας τρέχει την λέει η εντολή

uname -a

και υπάρχει και στην εντολή

inxi -F

Για το manjaro από γραμμή εντολών μπορούμε να δούμε ποιοι πυρήνες είναι εγκατεστημένοι με

mhwd-kernel -li

Ποιοι πυρήνες είναι διαθέσιμοι με την εντολή

mhwd-kernel -l

και εγκαθιστούμε πυρήνες με την εντολή

sudo mhwd-kernel -i linux54

όπου αντί για linux54 βάζεις όποιον θες από τούς διαθέσιμους. Αν δεν έχεις τον 5.4 προτείνω να βάλεις τον 5.4. (είναι ο τελευταίος lts) αν έχεις τον 5.4 δοκίμασε άλλους.

1 Like

Παρέμεινε, επειδή όταν κάνεις επανεκκίνηση φορτώνει ο desktop manager(πιθανότατα ο lightdm θα είναι) και μέσω αυτού υπάρχει το πρόβλημα. Όταν τρέχεις το startx από tty δεν παρεμβάλλεται ο desktop manager γι’ αυτό και μπαίνεις κανονικά στην επιφάνεια εργασίας. Δοκίμασε και κάποιον άλλο desktop manager. Ο gdm νομίζω χρησιμοποιεί διαφορετικό τρόπο σύνδεσης στην επιφάνεια εργασίας απ’ τον lightdm και κάποιους άλλους, οπότε δοκίμασε αυτόν πρώτα. Αφού τον εγκαταστήσεις δίνεις την εντολή:

sudo systemctl disable lightdm

(αν αυτόν έχεις)

και μετά:

sudo systemctl enable gdm

και κάνε επανεκκίνηση.

2 Likes

Έπαιξε όμορφα, η λύση ήταν αυτή.
Σας ευχαριστώ όλους για την βοήθεια!

2 Likes

Αυτό το νήμα έκλεισε αυτόματα 2 ημέρες μετά την τελευταία απάντηση. Δεν επιτρέπονται πλέον νέες απαντήσεις.