Δέν καταφερα να εγκαταστήσω το Keybase

Δοκίμασα να κάνω την εγκατάσταση του Keybase απο το keybase.io
Την έκδοση για “Ubuntu, Debian, and friends” για 32-bit
ΕΙμαι σε Mint 19.2 Tina

Μου λεει: E: Unsupported file ./keybase_i386.deb given on commandline
Τί κανω λάθος; Τι πρέπει να κάνω σωστά;
καλημέρα

@FotisV δεν είναι αυτός ο τρόπος εγκατάστασης των .deb πακέτων. Αντί αυτού δώσε στο τερματικό σου

sudo dpkg -i keybase_i386.deb
1 Like

Και αν σου χτυπήσει σφάλμα για εξαρτήσεις (libappindicator1) δώσε και αυτήν :
sudo apt-get install -f
Αλλά από ότι κατάλαβα δεν θα έχεις γραφικό περιβάλλον σε 32-bit, θα το τρέχεις δηλαδή μόνο από τερματικό.

1 Like

Ναί παιδια ευχαριστώ. Αλλα δεν ξερω άν το κανω σωστά
και παντως μου βγαζει:

sudo apt-get install -f
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                  
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
0 αναβαθμίστηκαν, 0 νέο εγκατεστημένα, 0 θα αφαιρεθούν και 87 δεν αναβαθμίζονται

Οπότε καταλαβαίνω οτι δεν προχωράει τπτ…

Να τα πάρουμε από την αρχή.
Εγκατέστησες το keybase;
Εφόσον το έκανες δώσε και ένα
sudo apt update && sudo apt upgrade
να αναβαθμιστούν και τα υπολειπόμενα πακέτα.

1 Like

Οκει θα το κάνω εξαρχής κι επανέρχομαι

1 Like

Εγκαταστάθηκε το Keybase έκανα login και τρέχει οκ. :slight_smile:
Επίσης έγινε ενημέρωση κι εγκατάσταση πολλών εφαρμογών, -ευχαριστώ για τις βοήθειες σας
Τώρα,
ανοίγει απο τον Διαχειριστή Λογισμικού,
το βρίσκω με την αναζήτηση και κανω κλικ στη εκκίνηση…
Υπάρχει αλλος τρόπος; δηλαδή εικονιδιο επιφανειας εργασίας ή έχουμε περιορισμο όπως αναφέρει παραπάνω @Maras

Okey όλα λυθηκαν, εχω και εικονιδιο στην γραμμη του πίνακα εφαρμογών και γενικά τρέχει απρόσκοπτα η εφαρμογή. Να ειστε καλά :slight_smile:

2 Likes

TIP:
Για να μην χρειάζεται αυτό, εξαρχής κάνουνε εγκατάσταση με :

sudo apt install to_arxeio.deb

Γιατί δεν κάνεις απλά διπλό κλικ στο .deb για να κάνει εγκατάσταση;

Έτσι φαντάζομαι ότι θα το έκανε εγκατάσταση, γιατί έτσι αναφέρεται και στις οδηγίες αλλά έχει την εξής αναφορά https://keybase.io/docs/the_app/install_linux :

Stable Releases

Ubuntu, Debian, and friends

64-bit
curl --remote-name https://prerelease.keybase.io/keybase_amd64.deb
sudo apt install ./keybase_amd64.deb
run_keybase
32-bit
curl --remote-name https://prerelease.keybase.io/keybase_i386.deb
sudo apt install ./keybase_i386.deb
run_keybase -g # run without GUI; it is not supported on 32-bit Linux

Note: Installing Keybase will add our package repository , so that your system updates will update the Keybase package too. If you want to prevent that, run sudo touch /etc/default/keybase before installing.

Note: if your apt version is below 1.1, you won’t be able to install the package using the above instructions. Instead, do

# if you see an error about missing `libappindicator1` from the next
# command, you can ignore it, as the subsequent command corrects it
sudo dpkg -i keybase_amd64.deb
sudo apt-get install -f
2 Likes