Δεν φορτώνεται σωστά το plasma (;)

Κάνω εκκίνηση και βλέπω μία μαύρη οθόνη με φορτωμένα μόνο τα widgets και το tickr να μου φέρνει τα rss. Άλλη φορά βλέπω την εικόνα της Επιφάνειας εργασίας αλλά όχι τα εικονίδια (Το Έχω στην ρύθμιση “Προβολή φακέλου” και όχι στο “Επιφάνεια εργασίας” όπως τα λέει στα Ελληνικά). Με σκότωμα του X (Ctrl+Alt+Backspace) δεν λύνεται. Μόνο με επανεκκίνηση. Άλλοτε είναι εντάξει με επανεκκίνηση και άλλοτε θέλει και δεύτερη ή τρίτη φορά. Αυτό μυ το έκανε και όταν ήταν 22.04 πριν κανω την αναβάθμιση σε 22.10 .
Δεν έκανα καθαρή εγκατάσταση 22.10 .
Νόμιζα ότι έφταιγε που είχα τη ρύθμιση, να παιζει βίντεο το desktop. Ότι βαραίνει πολύ. Γι αυτό και άφησα απλή εικόνα.

Θέλω να βρω τα log του φορτώματος και 1538η φορά δεν θυμάμαι. Τις 739 φορές μου έχετε πει εδώ τι κάνω. Κάτι με την tail, η Auth.log, Κάτι τέλος πάντων.

Θα μου πείτε για 740η φορά; :pensive:

Βεβαίως δεν θυμάμαι ποτέ να είχα τέτοια θέματα στην Arch. Ψήνομαι, αλλά εντάξει. Δεν έχω χαλάσει αρκετά ακόμα την kubuntu.

Ελεήστε χριστιανοί!

Πολύ κοινό πρόβλημα στο Plasma με διάφορες διανομές.
Bug απο τα παλιά, του οποίου μάλιστα η κατάσταση έχει επιδεινωθεί τελευταία (μέχρι πριν λίγο καιρό που είχα το plasma το έκανε πολύ συχνότερα απ’ ότι παλιά).

btw παρακολουθώ στο youtube αραιά και που έναν dev του KDE.
Σχολιάζοντας επιθυμίες χρηστών σε ενα βίντεο είπε μεταξύ άλλων “αν πούμε για ένα χρόνο να ασχοληθούμε με το bug fixing δεν θα προσθέσουμε νεα feautures στο KDE Plasma. 1 χρόνος χωρίς νέα feautures είναι 3 εκδόσεις, οι άνθρωποι θα νομίζουν οτι το KDE είναι νεκρό προτζεκτ και σιγά-σιγά θα το εγκαταλείπουν ή δεν θα θέλουν να ασχοληθούν μ’ αυτό”.

Δικό μου σχόλιο πάνω στην τοποθέτηση του dev: Αυτό δεν θα το νομίσουν σε καμία περίπτωση οι απλοί οικειακοί χρήστες, οι επαγγελματίες αλλά και οι developers των διανομών με την σωστή επικοινωνία. Θα το νομίσουν όμως (και θα φροντίσουν να το επικοινωνήσουν παραέξω) κάτι linux reviewers στο youtube, κάτι χομπίστες, enthousiasts και οι αιώνιοι distrohoppers. Η δεύτερη κατηγορία αν και αποτελεί μια μειοψηφία κάνει περισσότερο θόρυβο με αποτέλεσμα φορές να διαμορφώνει δημοφιλείς απόψεις και να επηρεάζει καταστάσεις.

Σε κάθε περίπτωση, σκεπτόμενος οτι bugs 8ετίας και 10ετίας μένουν αναρτήσεις στο KDE Bugzilla, οτι η κατάσταση τελευταία επιδεινώθηκε σε αυτό το ζήτημα αλλά και οτι είμαστε εν όψει huge αναβαθμίσεων (plasma 6 και wayland) που σύμφωνα με την εμπειρία απο το παρελθόν θα φέρουν ακόμα περισσότερα bugs τα οποία θα χρειαστεί ενα μεγάλο διάστημα να επιλυθούν και να επέλθει μια σχετική σταθερότητα, αποφάσισα να πορευτώ χωρίς το KDE για μερικά χρόνια και να πάω με το mint και το cinnamon.

Για να είμαι δίκαιος βέβαια τα τελευταία χρόνια οι devs του KDE φαίνεται να έχουν δώσει περισσότερη βαρύτητα στα bugs αλλά κατά την άποψη μου too little & too late.

Βέβαια το σεντόνι που έγραψα, δεν βοηθάει ιδιαίτερα ως προς την επίλυση του προβλήματος σου, και ζητώ συγνώμη γι αυτό, αλλά μιας και είχα παρόμοια προβλήματα που με ανάγκασαν να εγκαταλείψω το αγαπημένο μου Plasma, ήθελα κι εγώ κάπου να πω τον πόνο μου :innocent:

1 «Μου αρέσει»

Σε άλλον χρήστη (εάν έχεις στο σύστημα) πώς είναι τα πράγματα? Μήπως είναι κάποιο malfunction από κάποιο widget (δεν έχεις και λίγα)? Ο χώρος στον /home φάκελο σου πώς είναι, μήπως γεμίζει? Πόση RAM χρησιμοποιείς και πόση έχεις διαθέσιμη?

Αν βοηθάει και η δική μου εμπειρία δε χρησιμοποιούσα καθόλου widgets στην επιφάνεια εργασίας και μου το έκανε. Μετά απο ενα σημείο είχα καταργήσει και το win-7 show desktop στο panel και είχα το minimize all windows του plasma. Και με κανένα εξωτερικό widget σε panel και desktop πάλι μου το έκανε. Χρησιμοποιούσα όμως εξωτερικά Kwin Scripts…
Έδειχνε μόνο την επιφάνεια εργασίας, ούτε εικονίδια, ούτε το panel. Έστρωνε μόνο επανεκκίνηση και φορές στην 2η/3η - όπως τα λέει ο @Poor. Κάποιες φορές bootαρα σε μια μαύρη οθόνη μόνο με τον cursor να λειτουργεί.

Απο ραμ είχα 8 gigabyte, έφταναν και περίσσευαν, το plasma δεν έτρωγε πολλούς πόρους. Είχα και swap ίδιας χωρητικότητας. Απο χώρο το partition του distro ήταν γύρω στα 50gb αλλά δεν είχα θέμα χώρου, χρησιμοποιούσα ένα ext4 partition στον HDD για υποβοήθηση (εκεί έστελνα για παράδειγμα τα αρχεία του wine και του playonlinux, το cache του stremio και πράγματα γενικώς που τρώνε χώρο).

Είναι πολύ κοινό πρόβλημα και δεν είναι τωρινό, ούτε αφορούσε συγκεκριμένη υλοποίηση plasma μιας και μόνο διανομής, μου το έκανε ανέκαθεν αλλά κάπως σπάνια και δεν με πείραζε τόσο παλαιότερα, τον τελευταίο καιρό όμως είχε αυξηθεί κατά πολύ η συχνότητα. Υπάρχουν αναφορές για διάφορες διανομές στα ιντερνέτια τόσο για black screen after boot όσο και για empty desktop after log-in. Κάπως έτσι.

Φυσικά σε άλλο τοπικ θα μπορούσα να αναφέρω και άλλα κουλά bugs που έχω συναντήσει μέσα στα χρόνια χρησιμοποιώντας το plasma :confused:

1 «Μου αρέσει»

Άλλον χρήστη δοκίμασες για σύγκριση, μήπως το πρόβλημα έγκειται σε προβληματικό profile?

Οχι δεν το είχα κάνει.
Τώρα πλέον είναι αργά για να δοκιμάσω οτιδήποτε. Έχει μπει το mint και στα δύο μηχανήματα στην θέση Manjaro KDE και KDE Neon.

Μπορεί όμως ο Poor να δοκιμάσει πραγματάκια και να μας δώσει πληροφορίες.

1 «Μου αρέσει»

Δεν έχω άλλο χρήστη.
Έχω 26 γίγα ελεύθερα.
Widgets έχω το web broser (γιατί το άλλο θυμάσαι) κι ένα ραδιάκι. Το tickr το λέμε widget; Και τα xwinwrap
Και η μνήμη

$ free
               total        used        free      shared  buff/cache   available
Mem:        16300972     3698268     8906588       91828     3696116    12173408
Swap:        7812092           0     7812092

Έχω 16 γίγα με 3200 συχνότητα και cas latency 14.
Ο επεξεργαστής είναι ο Ryzen 9 5900
Η κάρτα γραφικών όμως είναι η 710

Καλά έκανες και χρήσιμα αυτά που μου είπες. Αλλά μου άρεσε πάντα το kde. Το ψώνιο που έχω με διάφορα μπιχλιμπίδια δεν μπορώ να το κάνω με άλλο περιβάλλον.

Να φτιάξω λες; Να μπαίνω καμιά βδομάδα να δούμε;

Ναι φτιάξε έναν χρήστη με τα ίδια χαρακτηριστικά στην επιφάνεια εργασίας, και δες πώς θα πάει. Αλλά έγραψες κάτι που προκαλεί σκέψεις.

Η κάρτα γραφικών όμως είναι η 710

Με βάση τα υπόλοιπα χαρακτηριστικά του υπολογιστή θα έχεις μεγάλο bottleneck, μάλλον είσαι στην μετάβαση για να πάρεις κάποια καλύτερη.
Είναι γνωστό το πρόβλημα με τις NVIDIA και τα Linux, πόσο μάλλον όταν πρόκειται για μια παλιά NVIDIA, το έχω βιώσει από πρώτο χέρι με μία 730. Έχεις κλειστούς οδηγούς? Εάν ναι λογικά την έκδοση 390.XXΧ (legacy drivers πλέον), μπορεί και την 340.ΧΧΧ?
Νομίζω ότι είναι για απόσυρση πλέον αυτές οι κάρτες όσο εξελίσσονται οι πυρήνες, γιατί δεν υπάρχει σωστή υποστήριξη από την εταιρία.
Κρίμα να έχεις 5900 με τέτοια κάρτα. Ποιά υλοποίηση είναι?

Έπαιρνα τα κομμάτια, ένα κάθε μήνα. Ο στόχος ήταν να φτιάξω ό,τι πιο δυνατό μπορώ. Ξεκίνησα Οκτώβρη και το έστησα Μάιο για να καταλάβεις. Θα έπαιρνα καλή κάρτα αλλά με πρόλαβες ο Δεκέμβρης που οι τιμές τριπλασιάστηκαν. Αναγκαστικά πήρα μία του 50ρικου κι όταν έστρωνε η κατάσταση θα χτύπαγα μία καλά. Τελικά βολεύτηκα έτσι και δεν το κυνήγησα. Αυτούς τους μήνες κάνουμε έξοδα για το σπίτι οπότε του χρόνου θα είμαι για άλλα έξοδα. Ήδη πήρα κρυφά το echo show 10 και μάλιστα πιο φτηνά γιατί μου το φέρνει το Φλεβάρη γιος μου από Αγγλία και άκουσα τα εξ αμάξης από τη γυναίκα μου.
Εντάξει ψέματα. Δεν με μαλώνει. Απλά αγχώνεται με τα έξοδα. Το να χαλάσω τώρα 3 και 4 κατοστάρικα δεν με παίρνει.

1 «Μου αρέσει»

Κι εγώ με πόνο ψυχής το άφησα με την υπόσχεση να ξαναβρεθούμε :sweat_smile:

Σίγουρα η 730 έχει περάσει σε 470χχ:


Σύμφωνα με αυτό εδώ (καρτέλλα supported products), και η 710 (θα έπρεπε να) φοράει τους ίδιους.

Όχι όλες, κάνε αναζήτηση εδώ με τον όρο 730 για να δείς ότι κάποιες είναι στην κατηγορία 390.ΧΧ :

http://us.download.nvidia.com/XFree86/Linux-x86_64/470.161.03/README/supportedchips.html

η δική μου ήταν μια τέτοια περίπτωση.

1 «Μου αρέσει»

Πιστεύω πως το σκεπτικό τού @Maras (να τσεκάρεις την κάρτα γραφικών και τούς οδηγούς της), έχει βάση.

Οι δικοί μου drivers ήταν ανοιχτού κώδικα. Και είχα τα ίδια 2 προβλήματα με τον Poor.

Έχω τον 470 (ιδιοταγής, δκιμασμενος - έτσι λέει).
Όμως τον ίδιον έχω και στην ubuntu με περιβάλλον mate και πάει μια χαρά.
Επίσης θυμάμαι κάτι που διαφωνεί με το Βασίλη. Με Arch δεν μου έκανε ποτέ τέτοια. αλλά μιλάμε για ποτέ. Ακόμα και στον παλιό υπολογιστή που είχα με κάρτα 20ετίς και φτηνή και θυμάμαι ότι έπαιρνε τον 340. Ενώ με kubuntu έκανε και πάλι τα περίεργά του.

Μου τα έκανε και με manjaro.
Μάλιστα το πρόβλημα το έχω αναφέρει εδώ μέσα στο άσχετο κάνα μήνα πριν

1 «Μου αρέσει»