Δεν έχω ήχο σε καμία διανομή linux.

Όπως αναφέρω στον τίτλο δεν έχω ήχο, οποιαδήποτε διανομή και αν δοκιμάσω. Στον υπολογιστή μου χρησιμοποιώ ποια Manjaro.

inxi -F
System:    Host: alex Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 Desktop: GNOME 3.36.6 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX505GE_FX505GE v: 1.0 serial: <superuser/root required> 
           Mobo: ASUSTeK model: FX505GE v: 1.0 serial: <superuser/root required> UEFI: American Megatrends v: FX505GE.307 
           date: 05/25/2020 
Battery:   ID-1: BAT0 charge: 42.0 Wh condition: 43.9/48.1 Wh (91%) 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP L2 cache: 9216 KiB 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 801 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia v: 450.66 
           Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
           Display: x11 server: X.org 1.20.8 driver: modesetting,nvidia resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.7 
Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: sof-audio-pci 
           Sound Server: ALSA v: k5.8.6-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
           IF: wlo1 state: up mac: a0:a4:c5:c8:6f:22 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: 04:92:26:17:6b:5b 
Drives:    Local Storage: total: 1.03 TiB used: 33.54 GiB (3.2%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM128GDJTNG-8310A size: 119.24 GiB 
           ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
Partition: ID-1: / size: 195.86 GiB used: 33.52 GiB (17.1%) fs: ext4 dev: /dev/sda1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 27.8 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 352 Uptime: 29m Memory: 7.63 GiB used: 2.67 GiB (35.0%) Shell: Zsh inxi: 3.1.05 

Μετά την εγκατάσταση της διανομής και χωρίς να κάνω καμιά επέμβαση στο λειτουργικό, στις ρυθμίσεις του gnome φαίνεται μόνο μια εικονική έξοδος:



Στην συνέχεια εγκατέστησα το πακέτο sof-firmware του sofproject.
Μετά την εγκατάσταση του πακέτου, αν και πάλι δεν έχω ήχο, στις ρυθμίσεις δεν δείχνει ποια την εικονική έξοδο:

Στο Alsamixer μπορω ποια να επιλεξω sound card με το F6:


και να δω αυτό:

αν επιλέξω την sof-hda-dsp, ωστόσο ακόμα δεν εχω ήχο.

Alsa information: http://alsa-project.org/db/?f=a22501fd655f2413de4f5c7577e953138edbcb6b

1 Like

Αν τα πας καλα με τα Αγγλικα γιατι δεν το ποσταρεις στο https://forum.manjaro.org/ ?

Γρήγορη δοκιμή:

  1. Ανοίγεις ως root το αρχείο /etc/default/grub
  2. Βρίσκεις τη γραμμή GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (ενδέχεται να είναι λίγο διαφορετική σε εσένα, δεν έχει σημασία)
  3. Προσθέτεις αυτό: snd_hda_intel.dmic_detect=0 και αποθηκεύεις
  4. Επανεκκίνηση

Αν δε δουλέψει, επαναλαμβάνεις τα βήματα και αφαιρείς αυτό που πρόσθεσες.

4 Likes

με μια γρηγορη ματια μαλλον η λυση ειναι εδω

https://forums.linuxmint.com/viewtopic.php?t=302235

Το δοκίμασα, και πάλι δεν έχω ήχο. Αφαίρεσα την αλλαγή στο grub.

Το τελευταίο βήμα πριν το restart ειναι να τρέξεις update-grub2 ή sido update-grub2 αν δεν εισαι root και μετα restart

Δοκιμασε και δες αν δουλεύει

1 Like

Το αρχείο alsa-base.conf δεν υπήρχε στο /etc/modprobe.d/alsa-base.con . Το δημιούργησα εγώ και προσέθεσα μέσα του τη γραμμή “options snd-hda-intel model=clevo-p950”. Έκανα επανεκκίνηση αλλά το πρόβλημα παρέμεινε. Οι αλλαγές αναιρεθήκαν.

sudo update-grub
[sudo] password for alex: 
/etc/default/grub: γραμμή 5: snd_hda_intel.dmic_detect=0: εντολή δεν βρέθηκε

Κάτι κάνω λάθος μάλλον.

Απλα Σβήσε το τελευταίο " και βαλτο στο τέλος της γραμμής. Σώσε το βγες απο το gedit και μετα τρέξε το sudo update-grub2 και κάνε restart. Συνέχισε ακάθεκτος :) θα το καταφέρεις

2 Likes

Δούλεψε!!! Επισημαίνω την απάντηση του @Soulrain ως λύση. @GNUTechie και @Soulrain ευχαριστώ πάρα πολύ.

3 Likes

Εσύ το εριξες το τρίποντο εμείς την ασιστ σου στείλαμε :slight_smile:

1 Like

Για να λέμε και μερικά πράγματα που καλό είναι να λέγονται, πρόκειται για bug στον πυρήνα που, τουλάχιστον στο Arch, έχει κλείσει ως FIXED (από το upstream) με την έκδοση 5.5. Γιατί το Manjaro με πυρήνα 5.8 εξακολουθεί να έχει το bug, δεν το ξέρω.

2 Likes

Για να συνοψίσω και σε μελλοντική εγκατάσταση να το φτιάχνω αμέσως, τα βήματα είναι:

  1. Εγκατάσταση του πακέτο sof-firmware

  2. Μετά ανοίγω ως root το αρχείο /etc/default/grub βρισκω τη γραμμή GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3" και την κάνω GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3 snd_hda_intel.dmic_detect=0"

  3. Εκτελώ στο τερματικό sudo update-grub

  4. Επανεκκίνησή.

1 Like

Δεν είναι μόνο στο Manjaro αυτό το πρόβλημα αλλά σε όλες τις διανομές που έχω δοκιμάσει (ubuntu, pop-os, fedora, endeavour-os κ.α.) και με πυρήνες από 4.14 έως 5.8

μπράβο για τον πληρέστατο τρόπο διατύπωσης του προβλήματός σου!

3 Likes

Αυτό το νήμα έκλεισε αυτόματα 2 ημέρες μετά την τελευταία απάντηση. Δεν επιτρέπονται πλέον νέες απαντήσεις.