Debian 10 πρόβλημα με πληκτρολόγιο

γεια σας παιδια, ειμαι καινούριος στο φορουμ, έχω ένα πρόβλημα με την γραφή της γλώσσας στο debian 10 gnome, έχω κλασικά αγγλικα και ελληνικα στο πληκτρολογιο σητν γραφη, οταν αλλαζω να γραψω στα ελληνικα μου δειχνει οτι εχουν μπει τα ελληνικα οταν γραφω ομως γραφει στα αγγλικα, πρεπει να μπω στο keyboard layout να σβησω τα ελληνικα και να τα ξαναβαλω για να μπορεσω να γραψω. Οταν κανω επανεκκινηση τον υπολογιστη μου κανει ξανα το ιδιο προβλημα, γνωριζει καποιος πως μπορω να το λυσω?

Δώσε αυτήν την εντολή

setxkbmap -layout us,el

και πες μας τι γίνεται.

1 Like

δυστυχως οχι συνεχιζεται το προβλημα

Καλωσορισες @xose

Ανοιξε ενα τερματικο και γραψε:

apt search ‘input method’ | grep installed

και κανε copy/paste το αποτελεσμα εδω περα για να δουμε τι γινεται

1 Like

WARNING: apt does not have a stable CLI interface. Use with caution in scripts

αυτο μου βγαζει οταν πληκτρολογω την εντολη

Δοκίμασε αυτό

apt-cache search ‘input method’ | grep installed

οταν γραφω την εντολη που με ειπες, μου βγαζει αυτο το μηνυμα : WARNING: apt does not have a stable CLI interface. Use with caution in scripts

Αυτο το Warning ειναι απλα μια προειδοποιηση οτι το apt σε αυτη του την μορφη δεν ειναι απολυτα σταθερο για να χρησιμοποιηθει σε scripts. Δεν ειναι μυνημα λαθους. Απλα μας προειδοποιει.

Δεν μας πειραζει αυτο θελουμε απλα να δουμε τα αποτελεσματα του apt search που σου εδωσα η του apt-cache search που σου εδωσε ο @tkor δηλαδη τις γραμμες αμεσως μετα το Warning.

Αν δεν σου εβγαλε τιποτα αλλο παρα μονο το warning τοτε σου λειπουν δυο πακετα: το

gir1.2-ibus-1.0 και το libibus-1.0.5

μπορεις να τα κανεις εγκατασταση με μια εντολη απο το τερματικο:

sudo apt-get install gir1.2-ibus-1.0 libibus-1.0.5

και αν το συστημα σου ειναι σωστα σεταρισμενο θα σου ζητηθει ενας κωδικος (password). Αυτος ο κωδικος ειναι ο κωδικος που χρησιμοποιεις για να μπεις στην επιφανεια εργασιας σου. Επισεις θα σου ζητηθει να πεις ναι η οχι στα πακετα που προσπαθεις να εγκαταστησεις και τα παρελκομενα τους (πχ αλλα πακετα που χρειαζονται αυτα τα δυο για να δουλεψουν). Στην περιπτωση αυτη πατας Y (δηλαδη ναι) και περιμενεις να εγκατασταθουν.

Εαν αυτα τα δυο πακετα ειναι ηδη εγκατεστημενα μαζι με καποια αλλα θα πρεπει να δουμε οποτε θα πρεπει να μας κανεις ενα copy/paste

Τι έξοδο δίνει η εντολή
dconf read /org/gnome/desktop/input-sources/sources
;

Σε περίπτωση που δεν είναι κάτι περεμφερές με [('xkb', 'us'), ('xkb', 'gr')]
μπορείς να το ρυθμίσεις με ένα:
dconf write /org/gnome/desktop/input-sources/sources "[('xkb', 'us'),('xkb', 'gr')]".

Επίσης αν προτιμάς το Alt+Shift για αλλαγή διάταξης αντί του default Super+Space, μπορείς να το ρυθμίσεις με:
dconf write /org/gnome/desktop/input-sources/xkb-options "['grp:alt_shift_toggle']"

Βοήθησε σε τίποτα, και αν ναι, συνεχίζεται το πρόβλημα όπου χάνεται η ρύθμιση μετά από μια επανεκκίνηση;

@GNUTechie και τα 2 ειναι εγκαταστημενα αυτο ειναιι το output :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libibus-1.0-5' for regex 'libibus-1.0.5'
libibus-1.0-5 is already the newest version (1.5.19-4+deb10u1).
The following packages were automatically installed and are no longer required:
  gir1.2-keybinder-3.0 gnome-session-canberra libkeybinder-3.0-0
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

@Turtle δυστυχως δεν αλλαξε κατι

Η συμπεριφορά αυτή μου ακούγεται πολύ παράξενη, μάλλον πρόκειται για bug και όχι θέμα λάθος ρύθμισης. Το πρόβλημα αυτό εμφανίζεται σε όλες τις περιπτώσεις εισαγωγής κειμένου, δηλαδή σε web browser, text editor, τερματικό κτλ; Επίσης, είναι πρόσφατο φαινόμενο ή το παρατήρησες από την αρχή της εγκατάστασης; Είχε εμφανιστεί σε άλλες διανομές/περιβάλλοντα εργασίας;

@Turtle σε ολα αυτα που προανεφερες, στο debian 9 me gnome 3 δεν το ειχε το προλημα, στο debian 10 εχει, δοκιμασα και αλλα desktop οπως ειναι το KDE MATE δεν ειχε προβλημα, πιστευω οτι ειναι καποιο bug του gnome

Θα πας ρυθμίσεις και θα ξε-τικαρεις την επιλογή “ίδια γλώσσα σε όλα τα παράθυρα”, μου έχει συμβεί και σε μένα ακριβώς το ίδιο

@al3xandr0s επειδή εχω την αγγλικη γλωσσα μπορεις να με καθοδηγησεις με screenshots

Θέλω να μου πείς εκδοση gnome

@al3xandr0s gnome 3.30.2

@al3xandr0s δυστυχως δεν εγινε, συνεχιζετε το προβλημα…

Αφού τίποτα δεν έπιασε απο όσα σου είπαμε…ΕΓΩ στην θέση σου θα έκανα το παρακάτω όχι τιποτα αλλο αλλα για να μήν σπάσω καμία οθόνη

su -
apt --purge remove gnome*
reboot
su -
apt install gnome*
1 Like

Προσωπικα θα ξεκινουσα με το εξης:

mv .config .config.backup

μετα ενα logout και ξανα ενα login.

Η εντολη αυτη μετακινει τον φακελο .config που κραταει τις περισσοτερες ρυθμισεις της επιφανειας εργασιας και που βρισκεται μεσα στο δικο σου home φακελο και θα δοκιμαζα να ξαναβαλω τις ρυθμισεις πληκτρολογιου σε περιπτωση που κατι αλλο αλλαξε και δεν αποθηκευοταν σωστα.

1 Like