CPU Ryzen 2400g


το pc καποιες φορες παγωνει και κλεινει μονο του ετρεξα το gtkstress και στα bug μου εβγαλε την φωτο που ανεβασα. ειμαι σε linux mint 19.3 μια βοηθεια αν μπορω να κανω κατι. ευχαριστω πολυ

Σημείωση: Η παραπάνω εικόνα είναι από bugs τής ίδιας τής CPU. Αυτά είναι bugs που έχει το υλικό και δεν έχει καμμία σχέση με το λειτουργικό. Το λειτουργικό από την άλλη έχει τρόπο συνήθως να τα αντιμετωπίζει. Μπορείς να δεις αν υπάρχει αντιμετώπιση με την εντολή

grep . /sys/devices/system/cpu/vulnerabilities/*

Αυτά τα bugs δεν έχουν σχέση με τα παγώματα που έχεις. Πιθανότατα όμως τα παγώματα σχετίζονται με τον πυρήνα. Αν πας σε προηγούμενο ή επόμενο ή αλλάξεις κάποια επιλογή είναι πιθανό να τα αποφύγεις.

Δώσε το αποτέλεσμα τής

inxi -F
 Kernel: 5.3.0-28-generic x86_64 bits: 64 
  Desktop: MATE 1.22.2 Distro: Linux Mint 19.3 Tricia 
Machine:
  Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <root required> 
  UEFI: American Megatrends v: P3.60 date: 07/31/2019 
CPU:
  Topology: Quad Core model: AMD Ryzen 5 2400G with Radeon Vega Graphics 
  bits: 64 type: MT MCP L2 cache: 2048 KiB 
  Speed: 1599 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 1596 2: 1597 
  3: 1597 4: 1603 5: 1590 6: 1596 7: 1594 8: 1589 
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  driver: amdgpu v: kernel 
  Display: x11 server: X.Org 1.20.5 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.33.0 5.3.0-28-generic LLVM 9.0.0) 
  v: 4.5 Mesa 19.2.8 
Audio:
  Device-1: AMD driver: snd_hda_intel 
  Device-2: AMD driver: snd_hda_intel 
  Sound Server: ALSA v: k5.3.0-28-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: 70:85:c2:be:34:a2 
Drives:
  Local Storage: total: 1.83 TiB used: 26.65 GiB (1.4%) 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB 
  ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
  ID-3: /dev/sdb vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 467.96 GiB used: 26.64 GiB (5.7%) fs: ext4 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 31.8 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 250 Uptime: 1m Memory: 13.59 GiB used: 666.5 MiB (4.8%) 
  Shell: bash inxi: 3.0.32

Μπορείς να βρεις περισσότερα για τα bugs της CPU εδώ

αλλά δεν είναι αυτά που προξενούν το πρόβλημα. Μιας και το έκανε και σε άλλο λειτουργικό είναι κάποιο θέμα στο υλικό, θερμοκρασίες, μνήμες, εκλεκτής δίσκου. Αρχικά θα είχα σε ένα τερματικό να παρακολουθώ τα logs και της θερμοκρασίες

tail -f /var/log/syslog
watch -d sensors

και να δω αν συμβαίνει κάτι ύποπτο πριν.

1 Like

παγωνει συχνα και συνηθως οταν ειμαι στον firefox. βεβαια το εκανε και στα win 10 οταν το ειχα dual boot αλλα τα εβγαλα.

Αυτήν την στιγμή όπως βλέπεις έχεις τον πυρήνα (kernel) 5.3
Θα έλεγα να δοκιμάσεις τούς πυρήνες 5.4 και 5.5 και να δεις αν έχεις πρόβλημα.
Δεν ξέρω πώς γίνεται στο Mint γιατί δεν το χρησιμοποιώ, θα μπορούσε να πει ο Talos. Αν δοκιμάσεις Manjaro η τρέχουσα έκδοση έχει τον 5.4 και είναι εύκολο να περάσεις και τον 5.5.

Επίσης μπορείς να δοκιμάσεις τον προηγομενο LTS που είναι το 4.19 αν και θέλεις κάπως να το αποφύγεις γιατί δεν θα έχεις εξίσου καλή υποστήριξη ειδικά για τα γραφικά σου.

σε ευχαριστω οπως εγραψα και απο πανω το εκανε και σε win 10 το συστημα το παρακολουθω και το προβλημα που εμφανισε ηταν οτι το ενας core ετρεχε στο 100 τις εκατο στον firefox.

Ετσι απο περιεργεια… για απενεργοποιησε το hardware acceleration στον Firefox και δες αν σου κολλαει παλι (η αν σου κολλησει πιο γρηγορα, εξαρταται απο την συμπερηφορα του συστηαμτος).

το εκανα και αυτο. το εκανε παλι σημερα.ασχολουμαι με αυτο το κομματι απο χθες. δεν εχω βγαλει ακρη ακομα.

Πάντως εγώ «επιμένω» στην δοκιμή πυρήνων γιατί δεν είναι καθόλου ασυνήθιστο τα τελευταία 10 χρόνια συγκεκριμένοι υπολογιστές να έχουν παγώματα με συγκεκριμένους πυρήνες που έχουν κάποια νέα επιλογή και η λύση σε αυτό είναι είτε απενεργοποίηση τής επιλογής (στον grub), είτε χρήση προηγούμενου πυρήνα που δεν είχε την επιλογή, είτε χρήση επόμενου πυρήνα που έχει λύσει το πρόβλημα.

1 Like

αυτο εβγαλε οταν κρασαρε χθες

Summary
Stack trace of thread 17535:
                #0  0x00007f828fbf4553 udisks_drive_get_revision (libudisks2.so.0)
                
                Stack trace of thread 17536:
                #0  0x00007f828d06ebf9 __GI___poll (libc.so.6)
                #1  0x00007f829047e5c9 n/a (libglib-2.0.so.0)
                #2  0x00007f829047e6dc g_main_context_iteration (libglib-2.0.so.0)
                #3  0x00007f829047e721 n/a (libglib-2.0.so.0)
                #4  0x00007f82904a6195 n/a (libglib-2.0.so.0)
                #5  0x00007f828d3526db start_thread (libpthread.so.0)
                #6  0x00007f828d07b88f __clone (libc.so.6)
                
                Stack trace of thread 17537:
                #0  0x00007f828d06ebf9 __GI___poll (libc.so.6)
                #1  0x00007f829047e5c9 n/a (libglib-2.0.so.0)
                #2  0x00007f829047e962 g_main_loop_run (libglib-2.0.so.0)
                #3  0x00007f82901620e6 n/a (libgio-2.0.so.0)
                #4  0x00007f82904a6195 n/a (libglib-2.0.so.0)
                #5  0x00007f828d3526db start_thread (libpthread.so.0)
                #6  0x00007f828d07b88f __clone (libc.so.6)
===================================================================
 GDB Log                                                           
===================================================================
[New LWP 17535]
[New LWP 17536]
[New LWP 17537]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/bin/gnome-disks --gapplication-service'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f828fbf4553 in udisks_drive_get_revision () from /usr/lib/x86_64-linux-gnu/libudisks2.so.0
[Current thread is 1 (Thread 0x7f8290935a80 (LWP 17535))]

===================================================================
 GDB Backtrace                                                     
===================================================================
[New LWP 17535]
[New LWP 17536]
[New LWP 17537]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/bin/gnome-disks --gapplication-service'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f828fbf4553 in udisks_drive_get_revision () from /usr/lib/x86_64-linux-gnu/libudisks2.so.0
[Current thread is 1 (Thread 0x7f8290935a80 (LWP 17535))]
#0  0x00007f828fbf4553 in udisks_drive_get_revision () from /usr/lib/x86_64-linux-gnu/libudisks2.so.0
#1  0x0000000000000000 in ?? ()

===================================================================
 GDB Backtrace (all threads)                                       
===================================================================
[New LWP 17535]
[New LWP 17536]
[New LWP 17537]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/bin/gnome-disks --gapplication-service'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f828fbf4553 in udisks_drive_get_revision () from /usr/lib/x86_64-linux-gnu/libudisks2.so.0
[Current thread is 1 (Thread 0x7f8290935a80 (LWP 17535))]

Thread 3 (Thread 0x7f8284a3b700 (LWP 17537)):
#0  0x00007f828d06ebf9 in __GI___poll (fds=0x55a2720cd760, nfds=3, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
        resultvar = 18446744073709551100
        sc_cancel_oldtype = 0
        sc_ret = <optimized out>
#1  0x00007f829047e5c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#2  0x00007f829047e962 in g_main_loop_run () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#3  0x00007f82901620e6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
No symbol table info available.
#4  0x00007f82904a6195 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#5  0x00007f828d3526db in start_thread (arg=0x7f8284a3b700) at pthread_create.c:463
        pd = 0x7f8284a3b700
        now = <optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140198547797760, 1894849823353545556, 140198547795072, 0, 94156186415344, 140725096213504, -1923368437741837484, -1923387004704840876}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <optimized out>
#6  0x00007f828d07b88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95
No locals.

Thread 2 (Thread 0x7f828523c700 (LWP 17536)):
#0  0x00007f828d06ebf9 in __GI___poll (fds=0x55a2720b63f0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
        resultvar = 18446744073709551100
        sc_cancel_oldtype = 0
        sc_ret = <optimized out>
#1  0x00007f829047e5c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#2  0x00007f829047e6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#3  0x00007f829047e721 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#4  0x00007f82904a6195 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
No symbol table info available.
#5  0x00007f828d3526db in start_thread (arg=0x7f828523c700) at pthread_create.c:463
        pd = 0x7f828523c700
        now = <optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140198556190464, 1894849823353545556, 140198556187776, 0, 94156186415184, 140725096213120, -1923369537790336172, -1923387004704840876}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <optimized out>
#6  0x00007f828d07b88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95
No locals.

Thread 1 (Thread 0x7f8290935a80 (LWP 17535)):
#0  0x00007f828fbf4553 in udisks_drive_get_revision () from /usr/lib/x86_64-linux-gnu/libudisks2.so.0
No symbol table info available.
#1  0x0000000000000000 in ?? ()
No symbol table info available.
#0  0x00007f828fbf4553 in udisks_drive_get_revision () from /usr/lib/x86_64-linux-gnu/libudisks2.so.0
#1  0x0000000000000000 in ?? ()

Δοκίμασε πρώτα ένα bios upgrade γιατί το mobo σου έχει 3.6 και έχει βγεί 3.9 από το Δεκέμβριο.
Από τροφοδοσία είσαι οκ ;
Το μηχάνημα παγώνει τυχαία η όταν ανοίγεις πχ firefox ,chrome etc και παράλληλα ένα hd video;
Τρέξε και επίσης μια εντολή sensors στο +12v bus να δεις τι σου φέρνει όταν ανοίγεις browser.

στον firefox παγωνει και στα δυο λειτουργικα οταν τα ειχα.

Για σήκωσε τον firefox από terminal σε safe mode και δες τι κάνει…

H πείρα δείχνει ότι η πρώτη σε ποσοστό αιτία για παγώματα του υπολογιστή είναι η μνήμη. Μπορώ να μάθω σε ποια συχνότητα παίζεις τις μνήμες σου;

sudo dmidecode --type 17

δεν της εχω ανεβασει εχω αφησει το προφιλ 1 στο bios
2133 και 1.2 ν

Δεν τρέχεις μερικά passes memtest να είμαστε σίγουροι ότι δεν είναι μνήμες?

θα το δοκιμασω και αυτο.

επανηλθα και αυτο που προλαβα να δω στην παρακολουιηση συστηματος ειναι οτι καρφωνει ξαφνικα στο εκατο τις εκατο ενα core της cpu τι λυση υπαρχει γαυτο;;
Καλημερα σας.τελικα μετα απο ενα ξενυχτι ακομα και κανα δυο κολληματα αφου ειδα οτι το ενα core εφτανε στο 100% ειπα να πειραξω τις μνημες και τις ανεβασα απο 2133 απο το προφιλ της μητρικης στα 3000και το τεσταρα και εχθες βραδυ και σημερα και βλεπω δεν εχει κολλησει ακομα.

Είχα τέτοιο θέμα παγώματος, αλλά έφταιγε ο firefox. Αν περίμενα κάμποση ώρα ξεκολούσε ή τον έκανα kill μέσω ssh.
Τελικά έκανa ένα Refresh τον firefox, και δεν το έχει ξανακάνει.

1 Like

Καλώς ήρθες @Theodore_Dimitriadis στην παρέα μας :hugs:

1 Like