Αδυναμία προσάρτησης εξωτερικού δίσκου

Έχω έναν εξωτερικό δίσκο ο οποίος δεν κάνει αυτόματη προσάρτηση σε λάπτοπ με linux mint 19.3 xfce.

Η lsblk δίνει

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 111,8G  0 disk 
├─sda1   8:1    0    40G  0 part 
└─sda2   8:2    0  71,8G  0 part /
sdb      8:16   0 931,5G  0 disk 
└─sdb1   8:17   0 931,5G  0 part 
sr0     11:0    1  1024M  0 rom 

Όταν δίνω sudo mount /dev/sdb1 /mnt
παίρνω:

Περίληψη
ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

Παρακαλώ τα φώτα σας!

:) ποιο μοντέλο δίσκου είναι, αλλά κυρίως:

  • είναι σε καλή λειτουργική κατάσταση (αποτέλεσμα smart /chkdisk?),
  • το καλώδιο?
  • γενικά ακούς κεφαλή να κολλάει?
  • είχε άτσαλη χρήση (πτώσεις) ποτέ?
  • τι διασύνδεση έχει ο δίσκος κ το laptop? (usb2 /3?)
  • το καλώδιο παίζει με άλλο δίσκο, σε άλλο ή στο ίδιο μηχάνημα?
  • ο δίσκος με άλλο καλώδιο?
  • ο δίσκος σε άλλο pc? με τι διασύνδεση? αμέσως ή αργεί?
  • η θύρα laptop με άλλα μέσα δείχνει αξιόπιστη?
  • έψαξες το μοντέλο δισκου κ laptop για γνωστές βλάβες?

Μοντέλο δίσκου: western Digital My Passport
Δεν ακούγεται κάτι περίεργο
Ο δίσκος είναι usb3 αλλά το λάπτοπ είναι usb2
Δεν έχω δυνατότητα να δοκιμάσω διαφορετικά υλικά η σε διαφορετικό μηχάνημα.
Η θύρα δουλεύει με άλλα περιφεριακά
Δεν έχω ψάξει στο δίκτυο.

Να συμπληρώσω ότι ο δίσκος μπαίνει και σε win7 ίδιο λάπτοπ
Και δεύτερον, όταν κατσάρω τον δίσκο φαίνεται στον file manager αλλά δεν ανοίγει όταν το κλικάρω

Διαβάζοντας το μήνυμα που σου βγάζει η mount, το πρώτο που έρχεται στο μυαλό είναι ότι έχει κάποιο πρόβλημα το σύστημα αρχείων του δίσκου.

Αν θέλεις, δοκίμασε να κάνεις έναν έλεγχο του συστήματος αρχείων του δίσκου (είτε από τα windows, είτε από το GParted) μήπως βρεθεί και επιδιορθωθεί κάποιο σφάλμα.

Δοκιμασε με το ntfsfix. Λογικα θα δουλεψει

Μπορεις να γίνεις πιο συγκεκριμένος;

ακολουθησε τις οδηγιες απο το link

1 Like

Ευχαριστώ πολύ θα το κοιτάξω…

Δες τα δικαιώματα που έχει ο χρήστης

1 Like